aboutsummaryrefslogtreecommitdiffstats
path: root/net/qt4-network
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2011-05-07 17:09:45 +0800
committeravilla <avilla@FreeBSD.org>2011-05-07 17:09:45 +0800
commitcec057229090f90dbdd8665f2c07942a1b86e2ab (patch)
tree40975ab5dcf568bb079dfba18d8421642fe19599 /net/qt4-network
parent2cdaf7f139ffaeda95c201622c5ab2a91d5c0ea0 (diff)
downloadfreebsd-ports-gnome-cec057229090f90dbdd8665f2c07942a1b86e2ab.tar.gz
freebsd-ports-gnome-cec057229090f90dbdd8665f2c07942a1b86e2ab.tar.zst
freebsd-ports-gnome-cec057229090f90dbdd8665f2c07942a1b86e2ab.zip
- Update Qt to 4.7.3.
Submitted by: Raphael Kubo da Costa <kubito@gmail.com> via area51
Diffstat (limited to 'net/qt4-network')
-rw-r--r--net/qt4-network/Makefile1
-rw-r--r--net/qt4-network/files/patch-qsslcertificate107
-rw-r--r--net/qt4-network/files/patch-qsslsocket35
3 files changed, 0 insertions, 143 deletions
diff --git a/net/qt4-network/Makefile b/net/qt4-network/Makefile
index ac3d2433c4eb..083e3bad88f9 100644
--- a/net/qt4-network/Makefile
+++ b/net/qt4-network/Makefile
@@ -8,7 +8,6 @@
PORTNAME= network
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= net ipv6
PKGNAMEPREFIX= qt4-
diff --git a/net/qt4-network/files/patch-qsslcertificate b/net/qt4-network/files/patch-qsslcertificate
deleted file mode 100644
index a8511a9ac6a0..000000000000
--- a/net/qt4-network/files/patch-qsslcertificate
+++ /dev/null
@@ -1,107 +0,0 @@
-From 04e074e8d7c097295505e63565abdc7ca2b49f7b Mon Sep 17 00:00:00 2001
-From: Peter Hartmann <peter.hartmann@nokia.com>
-Date: Thu, 24 Mar 2011 14:42:22 +0100
-Subject: [PATCH] QSslCertificate: report fraudulent certificates as invalid
-
-There are some fraudulent certificates in the wild that are not valid;
-this patch introduces a blacklist of serial numbers of those
-certificates.
-
-Reviewed-by: Richard J. Moore
-Reviewed-by: Markus Goetz
-Task-number: QTBUG-18338
----
- src/network/ssl/qsslcertificate.cpp | 34 +++++++++++++++++--
- src/network/ssl/qsslcertificate_p.h | 1 +
- .../more-certificates/blacklisted1.pem | 19 +++++++++++
- .../more-certificates/blacklisted2.pem | 19 +++++++++++
- .../more-certificates/blacklisted3.pem | 19 +++++++++++
- .../more-certificates/blacklisted4.pem | 19 +++++++++++
- .../more-certificates/blacklisted5.pem | 19 +++++++++++
- .../more-certificates/blacklisted6.pem | 19 +++++++++++
- .../more-certificates/blacklisted7.pem | 19 +++++++++++
- .../more-certificates/blacklisted8.pem | 19 +++++++++++
- .../more-certificates/blacklisted9.pem | 19 +++++++++++
- tests/auto/qsslcertificate/tst_qsslcertificate.cpp | 11 ++++++
- 12 files changed, 213 insertions(+), 4 deletions(-)
- create mode 100644 tests/auto/qsslcertificate/more-certificates/blacklisted1.pem
- create mode 100644 tests/auto/qsslcertificate/more-certificates/blacklisted2.pem
- create mode 100644 tests/auto/qsslcertificate/more-certificates/blacklisted3.pem
- create mode 100644 tests/auto/qsslcertificate/more-certificates/blacklisted4.pem
- create mode 100644 tests/auto/qsslcertificate/more-certificates/blacklisted5.pem
- create mode 100644 tests/auto/qsslcertificate/more-certificates/blacklisted6.pem
- create mode 100644 tests/auto/qsslcertificate/more-certificates/blacklisted7.pem
- create mode 100644 tests/auto/qsslcertificate/more-certificates/blacklisted8.pem
- create mode 100644 tests/auto/qsslcertificate/more-certificates/blacklisted9.pem
-
-diff --git a/src/network/ssl/qsslcertificate.cpp b/src/network/ssl/qsslcertificate.cpp
-index 618ac79..a5cdf01 100644
---- ./src/network/ssl/qsslcertificate.cpp
-+++ ./src/network/ssl/qsslcertificate.cpp
-@@ -219,17 +219,19 @@ bool QSslCertificate::isNull() const
- Returns true if this certificate is valid; otherwise returns
- false.
-
-- Note: Currently, this function only checks that the current
-+ Note: Currently, this function checks that the current
- data-time is within the date-time range during which the
-- certificate is considered valid. No other checks are
-- currently performed.
-+ certificate is considered valid, and checks that the
-+ certificate is not in a blacklist of fraudulent certificates.
-
- \sa isNull()
- */
- bool QSslCertificate::isValid() const
- {
- const QDateTime currentTime = QDateTime::currentDateTime();
-- return currentTime >= d->notValidBefore && currentTime <= d->notValidAfter;
-+ return currentTime >= d->notValidBefore &&
-+ currentTime <= d->notValidAfter &&
-+ ! QSslCertificatePrivate::isBlacklisted(*this);
- }
-
- /*!
-@@ -798,6 +800,30 @@ QList<QSslCertificate> QSslCertificatePrivate::certificatesFromDer(const QByteAr
- return certificates;
- }
-
-+// These certificates are known to be fraudulent and were created during the comodo
-+// compromise. See http://www.comodo.com/Comodo-Fraud-Incident-2011-03-23.html
-+static const char *certificate_blacklist[] = {
-+ "04:7e:cb:e9:fc:a5:5f:7b:d0:9e:ae:36:e1:0c:ae:1e",
-+ "f5:c8:6a:f3:61:62:f1:3a:64:f5:4f:6d:c9:58:7c:06",
-+ "d7:55:8f:da:f5:f1:10:5b:b2:13:28:2b:70:77:29:a3",
-+ "39:2a:43:4f:0e:07:df:1f:8a:a3:05:de:34:e0:c2:29",
-+ "3e:75:ce:d4:6b:69:30:21:21:88:30:ae:86:a8:2a:71",
-+ "e9:02:8b:95:78:e4:15:dc:1a:71:0a:2b:88:15:44:47",
-+ "92:39:d5:34:8f:40:d1:69:5a:74:54:70:e1:f2:3f:43",
-+ "b0:b7:13:3e:d0:96:f9:b5:6f:ae:91:c8:74:bd:3a:c0",
-+ "d8:f3:5f:4e:b7:87:2b:2d:ab:06:92:e3:15:38:2f:b0",
-+ 0
-+};
-+
-+bool QSslCertificatePrivate::isBlacklisted(const QSslCertificate &certificate)
-+{
-+ for (int a = 0; certificate_blacklist[a] != 0; a++) {
-+ if (certificate.serialNumber() == certificate_blacklist[a])
-+ return true;
-+ }
-+ return false;
-+}
-+
- #ifndef QT_NO_DEBUG_STREAM
- QDebug operator<<(QDebug debug, const QSslCertificate &certificate)
- {
-diff --git a/src/network/ssl/qsslcertificate_p.h b/src/network/ssl/qsslcertificate_p.h
-index cdceb0f..1ce33d3 100644
---- ./src/network/ssl/qsslcertificate_p.h
-+++ ./src/network/ssl/qsslcertificate_p.h
-@@ -96,6 +96,7 @@ public:
- static QSslCertificate QSslCertificate_from_X509(X509 *x509);
- static QList<QSslCertificate> certificatesFromPem(const QByteArray &pem, int count = -1);
- static QList<QSslCertificate> certificatesFromDer(const QByteArray &der, int count = -1);
-+ static bool isBlacklisted(const QSslCertificate &certificate);
-
- friend class QSslSocketBackendPrivate;
-
diff --git a/net/qt4-network/files/patch-qsslsocket b/net/qt4-network/files/patch-qsslsocket
deleted file mode 100644
index 392613e40749..000000000000
--- a/net/qt4-network/files/patch-qsslsocket
+++ /dev/null
@@ -1,35 +0,0 @@
-From b87528a71b66e786c11804d7b79e408aae612748 Mon Sep 17 00:00:00 2001
-From: Peter Hartmann <peter.hartmann@nokia.com>
-Date: Fri, 25 Mar 2011 13:45:24 +0100
-Subject: [PATCH] QSslSocket internals: abort on encountering blacklisted certificates
-
-tested manually with "openssl s_server -cert blacklisted.pem -key
-key.pem" and connecting a QSslSocket.
-
-Reviewed-by: Markus Goetz
-Task-number: QTBUG-18338
----
- src/network/ssl/qsslsocket_openssl.cpp | 7 +++++++
- 1 files changed, 7 insertions(+), 0 deletions(-)
-
-diff --git a/src/network/ssl/qsslsocket_openssl.cpp b/src/network/ssl/qsslsocket_openssl.cpp
-index 0866534..2427193 100644
---- ./src/network/ssl/qsslsocket_openssl.cpp
-+++ ./src/network/ssl/qsslsocket_openssl.cpp
-@@ -1193,6 +1193,13 @@ bool QSslSocketBackendPrivate::startHandshake()
- X509 *x509 = q_SSL_get_peer_certificate(ssl);
- configuration.peerCertificate = QSslCertificatePrivate::QSslCertificate_from_X509(x509);
- q_X509_free(x509);
-+ if (QSslCertificatePrivate::isBlacklisted(configuration.peerCertificate)) {
-+ q->setErrorString(QSslSocket::tr("The peer certificate is blacklisted"));
-+ q->setSocketError(QAbstractSocket::SslHandshakeFailedError);
-+ emit q->error(QAbstractSocket::SslHandshakeFailedError);
-+ plainSocket->disconnectFromHost();
-+ return false;
-+ }
-
- // Start translating errors.
- QList<QSslError> errors;
---
-1.6.1
-