aboutsummaryrefslogtreecommitdiffstats
path: root/net/qt5-network/Makefile
diff options
context:
space:
mode:
authorcmt <cmt@FreeBSD.org>2018-04-02 06:38:06 +0800
committercmt <cmt@FreeBSD.org>2018-04-02 06:38:06 +0800
commiteffb87e6b7aa7e04eb43ff02779f7b172fb25279 (patch)
tree396c29dedb4e2cb3f3659b42892813e29fd6c6a1 /net/qt5-network/Makefile
parenta3f06f338e8482f5c13b9783a70a0ebbe588675b (diff)
downloadfreebsd-ports-gnome-effb87e6b7aa7e04eb43ff02779f7b172fb25279.tar.gz
freebsd-ports-gnome-effb87e6b7aa7e04eb43ff02779f7b172fb25279.tar.zst
freebsd-ports-gnome-effb87e6b7aa7e04eb43ff02779f7b172fb25279.zip
restore ssl functionality with openssl
The "libressl compatibility" unfortunately added a dependency on the SSL_CTX_set1_groups() function, which is neither available in base (for released versions of FreeBSD) nor ports openssl (it's only in openssl-devel and libressl). This broke SSL (most importantly HTTPS) functionalty in many Qt5-ports. This adds some #ifdefs around the SSL_CTX_set1_groups() calling sites and restores the old code in cases where libressl has not been detected. PR: 218421 Reported by: yuri Approved by: maintainer-timeout
Diffstat (limited to 'net/qt5-network/Makefile')
-rw-r--r--net/qt5-network/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/qt5-network/Makefile b/net/qt5-network/Makefile
index ff3f333a13ba..0cdcdd37c01d 100644
--- a/net/qt5-network/Makefile
+++ b/net/qt5-network/Makefile
@@ -2,7 +2,7 @@
PORTNAME= network
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net ipv6
PKGNAMEPREFIX= qt5-