aboutsummaryrefslogtreecommitdiffstats
path: root/net/qt5-network
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /net/qt5-network
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadfreebsd-ports-gnome-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
freebsd-ports-gnome-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.zst
freebsd-ports-gnome-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'net/qt5-network')
-rw-r--r--net/qt5-network/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/net/qt5-network/Makefile b/net/qt5-network/Makefile
index 4ddf24cf6b5a..be2a9547dce0 100644
--- a/net/qt5-network/Makefile
+++ b/net/qt5-network/Makefile
@@ -13,9 +13,8 @@ BROKEN_SSL_REASON_openssl-devel= error: member access into incomplete type 'X509
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
-USES= ssl
-USE_QT5= core qmake_build buildtools_build
-QT_DIST= base
+USES= qmake:no_env qt-dist:5,base ssl
+USE_QT= core buildtools_build
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -no-gui -no-xcb
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}