aboutsummaryrefslogtreecommitdiffstats
path: root/net/quagga
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2008-01-11 22:06:45 +0800
committersem <sem@FreeBSD.org>2008-01-11 22:06:45 +0800
commit152d46fc2c1b201b7cbf0610d0403dd6a6aa57ab (patch)
tree5c760e5cd517bf6d2b32e68db4309a7fadc85770 /net/quagga
parent5c7dd3c7d10956f2f31f5f3d40d7c76106942b64 (diff)
downloadfreebsd-ports-gnome-152d46fc2c1b201b7cbf0610d0403dd6a6aa57ab.tar.gz
freebsd-ports-gnome-152d46fc2c1b201b7cbf0610d0403dd6a6aa57ab.tar.zst
freebsd-ports-gnome-152d46fc2c1b201b7cbf0610d0403dd6a6aa57ab.zip
- Add a work around for quagga works with multicast sockets in 7.0.
Submitted by: maintainer
Diffstat (limited to 'net/quagga')
-rw-r--r--net/quagga/Makefile2
-rw-r--r--net/quagga/files/patch-lib-sockopt.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 3723b2917034..c34da443d541 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quagga
PORTVERSION= 0.99.9
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net ipv6
MASTER_SITES= http://quagga.net/download/ \
http://www.ru.quagga.net/download/ \
diff --git a/net/quagga/files/patch-lib-sockopt.c b/net/quagga/files/patch-lib-sockopt.c
new file mode 100644
index 000000000000..5995b3756e5f
--- /dev/null
+++ b/net/quagga/files/patch-lib-sockopt.c
@@ -0,0 +1,13 @@
+--- lib/sockopt.c.orig 2008-01-11 16:47:21.000000000 +0300
++++ lib/sockopt.c 2008-01-11 16:47:57.000000000 +0300
+@@ -23,6 +23,10 @@
+ #include "log.h"
+ #include "sockopt.h"
+
++#ifdef HAVE_STRUCT_IP_MREQN_IMR_IFINDEX
++#undef HAVE_STRUCT_IP_MREQN_IMR_IFINDEX
++#endif
++
+ int
+ setsockopt_so_recvbuf (int sock, int size)
+ {