aboutsummaryrefslogtreecommitdiffstats
path: root/net/quagga
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-09-15 07:48:12 +0800
committerpav <pav@FreeBSD.org>2005-09-15 07:48:12 +0800
commitd72a6ce3f774dc4f32d3cc9f832ddae8b0f64633 (patch)
tree561e8ff4b881781698c6bcba2b4df3a8b8d58556 /net/quagga
parent344c805ab95198272761a6fa58c34c6a518f0446 (diff)
downloadfreebsd-ports-gnome-d72a6ce3f774dc4f32d3cc9f832ddae8b0f64633.tar.gz
freebsd-ports-gnome-d72a6ce3f774dc4f32d3cc9f832ddae8b0f64633.tar.zst
freebsd-ports-gnome-d72a6ce3f774dc4f32d3cc9f832ddae8b0f64633.zip
- Kludge snmp detection in configure script
PR: ports/86102 Submitted by: Boris Kovalenko <boris@tagnet.ru> (maintainer)
Diffstat (limited to 'net/quagga')
-rw-r--r--net/quagga/Makefile4
-rw-r--r--net/quagga/files/patch-configure42
2 files changed, 44 insertions, 2 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index f07c935e7188..1637d2e11617 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -19,6 +19,7 @@ COMMENT= Free RIPv1, RIPv2, OSPFv2, BGP4, IS-IS route software
CONFLICTS= zebra-devel-[0-9]* zebra-0*
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
@@ -41,8 +42,7 @@ OPTIONS= ISISD "Enable experimental ISIS daemon" off \
.include <bsd.port.pre.mk>
-CONFIGURE_ARGS+=--includedir=${PREFIX}/include --enable-exampledir=${PREFIX}/share/examples/quagga \
- --program-transform-name=""
+CONFIGURE_ARGS+=--includedir=${PREFIX}/include --enable-exampledir=${PREFIX}/share/examples/quagga
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} \
diff --git a/net/quagga/files/patch-configure b/net/quagga/files/patch-configure
new file mode 100644
index 000000000000..ad68f3227038
--- /dev/null
+++ b/net/quagga/files/patch-configure
@@ -0,0 +1,42 @@
+--- configure.orig Sun Aug 28 21:37:37 2005
++++ configure Wed Sep 14 12:07:40 2005
+@@ -14751,13 +14751,13 @@
+ fi
+
+ if test "${HAVE_SNMP}" = "yes"; then
+- for ac_snmp in /usr/include/net-snmp/library/asn1.h /usr/include/ucd-snmp/asn1.h /usr/local/include/ucd-snmp/asn1.h /dev/null
++ for ac_snmp in /usr/local/include/net-snmp/library/asn1.h /usr/local/include/ucd-snmp/asn1.h /usr/local/include/ucd-snmp/asn1.h /dev/null
+ do
+ test -f "${ac_snmp}" && break
+ done
+
+ case ${ac_snmp} in
+- /usr/include/net-snmp/*)
++ /usr/local/include/net-snmp/*)
+
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_SNMP
+@@ -14773,20 +14773,20 @@
+ #define UCD_COMPATIBLE
+ _ACEOF
+
+- CFLAGS="${CFLAGS} -I/usr/include/net-snmp -I/usr/include/net-snmp/library"
++ CFLAGS="${CFLAGS} -I/usr/local/include/net-snmp -I/usr/local/include/net-snmp/library"
+ if test "${HAVE_NETSNMP}" = "yes"; then
+ LIBS="${LIBS} -lnetsnmp"
+ else
+ LIBS="${LIBS} -lsnmp"
+ fi
+ ;;
+- /usr/include/ucd-snmp/*)
++ /usr/local/include/ucd-snmp/*)
+
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_SNMP
+ _ACEOF
+
+- CFLAGS="${CFLAGS} -I/usr/include/ucd-snmp"
++ CFLAGS="${CFLAGS} -I/usr/local/include/ucd-snmp"
+ LIBS="${LIBS} -lsnmp"
+ ;;
+ /usr/local/include/ucd-snmp/*)