aboutsummaryrefslogtreecommitdiffstats
path: root/net/rtpbreak
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-28 16:59:46 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-28 16:59:46 +0800
commit639f0dec9ef35bbd66dff91abecdeee7f1606760 (patch)
tree5c310e87bfc8c278cce984af7d0724b9b4c9adee /net/rtpbreak
parentcd69cf4d391a67d8d3cf300ee54bf4168b260496 (diff)
downloadfreebsd-ports-gnome-639f0dec9ef35bbd66dff91abecdeee7f1606760.tar.gz
freebsd-ports-gnome-639f0dec9ef35bbd66dff91abecdeee7f1606760.tar.zst
freebsd-ports-gnome-639f0dec9ef35bbd66dff91abecdeee7f1606760.zip
- Support staging
- Respect CFLAGS - Don't force -O3 compiler optimization
Diffstat (limited to 'net/rtpbreak')
-rw-r--r--net/rtpbreak/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/net/rtpbreak/Makefile b/net/rtpbreak/Makefile
index 4c659241d779..6218ac640478 100644
--- a/net/rtpbreak/Makefile
+++ b/net/rtpbreak/Makefile
@@ -13,13 +13,14 @@ COMMENT= Detects, reconstructs, and analyzes any RTP session
LIB_DEPENDS= net:${PORTSDIR}/net/libnet
-MAKE_ARGS+= CFLAGS="-Wall -O3 -I${LOCALBASE}/include/libnet11" \
- LIBS="-L${LOCALBASE}/lib/libnet11 -lpcap -lnet"
+CFLAGS+= -I${LOCALBASE}/include/libnet11
+LIBS+= -L${LOCALBASE}/lib/libnet11 -lpcap -lnet
+
+MAKE_ARGS= CFLAGS="${CFLAGS}" LIBS="${LIBS}"
PLIST_FILES= bin/rtpbreak
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/rtpbreak ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/rtpbreak ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>