aboutsummaryrefslogtreecommitdiffstats
path: root/net/rubygem-grpc
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2019-11-23 16:46:16 +0800
committerMatthias Fechner <mfechner@FreeBSD.org>2019-11-23 16:46:16 +0800
commitf817179794e8cc7b6733df1d80fe522c6053f6c5 (patch)
treed4b901903677dc0e7909a3b8cfcb841d827d6723 /net/rubygem-grpc
parent81ed370ca644d6a6aae074f25a42d4f1eb3926c9 (diff)
downloadfreebsd-ports-gnome-f817179794e8cc7b6733df1d80fe522c6053f6c5.tar.gz
freebsd-ports-gnome-f817179794e8cc7b6733df1d80fe522c6053f6c5.tar.zst
freebsd-ports-gnome-f817179794e8cc7b6733df1d80fe522c6053f6c5.zip
Upgrade to 1.24.0 which is required fpr gitlab-ce 12.5.
Diffstat (limited to 'net/rubygem-grpc')
-rw-r--r--net/rubygem-grpc/Makefile6
-rw-r--r--net/rubygem-grpc/distinfo6
-rw-r--r--net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb17
3 files changed, 18 insertions, 11 deletions
diff --git a/net/rubygem-grpc/Makefile b/net/rubygem-grpc/Makefile
index da5f95e30ba7..f3612de9b9e3 100644
--- a/net/rubygem-grpc/Makefile
+++ b/net/rubygem-grpc/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= grpc
-PORTVERSION= 1.19.0
+PORTVERSION= 1.24.0
CATEGORIES= net rubygems
MASTER_SITES= RG
@@ -13,8 +13,8 @@ LICENSE= BSD3CLAUSE
LIB_DEPENDS= libcares.so:dns/c-ares \
libgrpc.so:devel/grpc
RUN_DEPENDS= ca_root_nss>=0:security/ca_root_nss \
- rubygem-google-protobuf>=3.1:devel/rubygem-google-protobuf \
- rubygem-googleapis-common-protos-types>=1.0.0:devel/rubygem-googleapis-common-protos-types
+ rubygem-googleapis-common-protos-types>=1.0<2.0:devel/rubygem-googleapis-common-protos-types \
+ rubygem-google-protobuf>=3.8<4.0:devel/rubygem-google-protobuf
MAKE_JOBS_UNSAFE= yes
diff --git a/net/rubygem-grpc/distinfo b/net/rubygem-grpc/distinfo
index de3d2c6f8041..fb5a432172df 100644
--- a/net/rubygem-grpc/distinfo
+++ b/net/rubygem-grpc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1558173766
-SHA256 (rubygem/grpc-1.19.0.gem) = faf11039fe32009ccc270190e33d65b1a5e0d292ddd06a2ffa7d97aae3e7bee5
-SIZE (rubygem/grpc-1.19.0.gem) = 3093504
+TIMESTAMP = 1574430162
+SHA256 (rubygem/grpc-1.24.0.gem) = eed268d73e455ed82df7e9a76a9575d11d3c1c139a95a227254b9286939c91a3
+SIZE (rubygem/grpc-1.24.0.gem) = 3264000
diff --git a/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb b/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
index 7c2525c0f0b2..1c9f7cb9dbe2 100644
--- a/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
+++ b/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
@@ -1,6 +1,6 @@
---- src/ruby/ext/grpc/extconf.rb.orig 2017-12-31 07:02:12 UTC
+--- src/ruby/ext/grpc/extconf.rb.orig 2019-11-22 13:44:33 UTC
+++ src/ruby/ext/grpc/extconf.rb
-@@ -56,9 +56,9 @@ ENV['LD'] = ENV['CC']
+@@ -39,9 +39,9 @@ end
ENV['AR'] = 'libtool -o' if RUBY_PLATFORM =~ /darwin/
@@ -13,7 +13,7 @@
ENV['ARCH_FLAGS'] = RbConfig::CONFIG['ARCH_FLAG']
ENV['ARCH_FLAGS'] = '-arch i386 -arch x86_64' if RUBY_PLATFORM =~ /darwin/
ENV['CPPFLAGS'] = '-DGPR_BACKWARDS_COMPATIBILITY_MODE'
-@@ -67,17 +67,18 @@ output_dir = File.expand_path(RbConfig::CONFIG['topdir
+@@ -50,22 +50,23 @@ output_dir = File.expand_path(RbConfig::CONFIG['topdir
grpc_lib_dir = File.join(output_dir, 'libs', grpc_config)
ENV['BUILDDIR'] = output_dir
@@ -35,10 +35,17 @@
+#end
-$CFLAGS << ' -I' + File.join(grpc_root, 'include')
--$LDFLAGS << ' ' + File.join(grpc_lib_dir, 'libgrpc.a') unless windows
+#$CFLAGS << ' -I' + File.join(grpc_root, 'include')
-+#$LDFLAGS << ' ' + File.join(grpc_lib_dir, 'libgrpc.a') unless windows
+
+ ext_export_file = File.join(grpc_root, 'src', 'ruby', 'ext', 'grpc', 'ext-export')
+-$LDFLAGS << ' -Wl,--version-script="' + ext_export_file + '.gcc"' if RUBY_PLATFORM =~ /linux/
+-$LDFLAGS << ' -Wl,-exported_symbols_list,"' + ext_export_file + '.clang"' if RUBY_PLATFORM =~ /darwin/
++#$LDFLAGS << ' -Wl,--version-script="' + ext_export_file + '.gcc"' if RUBY_PLATFORM =~ /linux/
++#$LDFLAGS << ' -Wl,-exported_symbols_list,"' + ext_export_file + '.clang"' if RUBY_PLATFORM =~ /darwin/
+$LDFLAGS << ' -lgrpc' unless windows
+
+-$LDFLAGS << ' ' + File.join(grpc_lib_dir, 'libgrpc.a') unless windows
++#$LDFLAGS << ' ' + File.join(grpc_lib_dir, 'libgrpc.a') unless windows
if grpc_config == 'gcov'
$CFLAGS << ' -O0 -fprofile-arcs -ftest-coverage'
$LDFLAGS << ' -fprofile-arcs -ftest-coverage -rdynamic'