aboutsummaryrefslogtreecommitdiffstats
path: root/net/samba3
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2006-10-12 04:40:35 +0800
committershaun <shaun@FreeBSD.org>2006-10-12 04:40:35 +0800
commitb76ea1585888c6afd27dccc8492c636cf4dbb305 (patch)
treed30c9367887a09dca2f1c89b7f0a598e4e24199f /net/samba3
parentfd7b987d433c50f9d4d8bce1a9786011fd3554ba (diff)
downloadfreebsd-ports-gnome-b76ea1585888c6afd27dccc8492c636cf4dbb305.tar.gz
freebsd-ports-gnome-b76ea1585888c6afd27dccc8492c636cf4dbb305.tar.zst
freebsd-ports-gnome-b76ea1585888c6afd27dccc8492c636cf4dbb305.zip
Fix a bug introduced by a previous patch, whereby pam_winbind.so would
fail to load correctly. PR: ports/104269 Submitted by: Dominic Marks <dom@helenmarks.co.uk> Approved by: portmgr (erwin)
Diffstat (limited to 'net/samba3')
-rw-r--r--net/samba3/Makefile2
-rw-r--r--net/samba3/files/patch-za2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/samba3/Makefile b/net/samba3/Makefile
index 4e8a0e42bc50..797437d5e9a0 100644
--- a/net/samba3/Makefile
+++ b/net/samba3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= samba
PORTVERSION?= 3.0.23c
-PORTREVISION?= 1
+PORTREVISION?= 2
PORTEPOCH?= 1
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SAMBA}
diff --git a/net/samba3/files/patch-za b/net/samba3/files/patch-za
index cadc4bb4c754..d92a775832ff 100644
--- a/net/samba3/files/patch-za
+++ b/net/samba3/files/patch-za
@@ -28,7 +28,7 @@
+ char *env;
+
+ if ((env=getenv(WINBINDD_DONT_ENV)) != NULL) {
-+ if(strequal(env, "1")) {
++ if(strcmp(env, "1")) {
+ return True;
+ }
+ }