aboutsummaryrefslogtreecommitdiffstats
path: root/net/samba4-devel
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2012-01-13 19:51:51 +0800
committerpav <pav@FreeBSD.org>2012-01-13 19:51:51 +0800
commit2c1bd92ef5253d2aef6e9c430a45b1c304469247 (patch)
treea062c2cb15493a185242536778fa5267fa4bf024 /net/samba4-devel
parent01e3274d613a6657795196077fa5be7904ca359b (diff)
downloadfreebsd-ports-gnome-2c1bd92ef5253d2aef6e9c430a45b1c304469247.tar.gz
freebsd-ports-gnome-2c1bd92ef5253d2aef6e9c430a45b1c304469247.tar.zst
freebsd-ports-gnome-2c1bd92ef5253d2aef6e9c430a45b1c304469247.zip
- Fix build and unbreak
PR: ports/163688 Submitted by: Takeharu KATO <takeharu1219@ybb.ne.jp> Approved by: maintainer timeout (timur; 15 days)
Diffstat (limited to 'net/samba4-devel')
-rw-r--r--net/samba4-devel/Makefile2
-rw-r--r--net/samba4-devel/files/patch-lib-talloc-pytalloc.c11
-rw-r--r--net/samba4-devel/files/patch-source4-param-pyparam_util.c11
3 files changed, 22 insertions, 2 deletions
diff --git a/net/samba4-devel/Makefile b/net/samba4-devel/Makefile
index 4ab1de052dc8..7b9424dfe5f6 100644
--- a/net/samba4-devel/Makefile
+++ b/net/samba4-devel/Makefile
@@ -18,8 +18,6 @@ COMMENT?= A free SMB and CIFS client and server for UNIX
CONFLICTS?= ldb-1.*
-BROKEN= does not compile
-
SAMBA_PORTNAME= samba4
SAMBA_VERSION= 4.0.0.a11
SAMBA_DISTNAME= ${SAMBA_PORTNAME:S|4$||}-${SAMBA_VERSION:S|.p|pre|:S|.r|rc|:S|.t|tp|:S|.a|alpha|}
diff --git a/net/samba4-devel/files/patch-lib-talloc-pytalloc.c b/net/samba4-devel/files/patch-lib-talloc-pytalloc.c
new file mode 100644
index 000000000000..ab07095110c5
--- /dev/null
+++ b/net/samba4-devel/files/patch-lib-talloc-pytalloc.c
@@ -0,0 +1,11 @@
+--- ./lib/talloc/pytalloc.c.orig 2010-01-11 07:35:28.000000000 +0200
++++ ./lib/talloc/pytalloc.c 2012-01-12 19:48:39.276126537 +0200
+@@ -19,7 +19,7 @@
+
+ #include "replace.h"
+ #include <talloc.h>
+-#include <pytalloc.h>
++#include "pytalloc.h"
+
+ /**
+ * Simple dealloc for talloc-wrapping PyObjects
diff --git a/net/samba4-devel/files/patch-source4-param-pyparam_util.c b/net/samba4-devel/files/patch-source4-param-pyparam_util.c
new file mode 100644
index 000000000000..878308198cf5
--- /dev/null
+++ b/net/samba4-devel/files/patch-source4-param-pyparam_util.c
@@ -0,0 +1,11 @@
+--- ./source4/param/pyparam_util.c.orig 2010-01-11 07:35:28.000000000 +0200
++++ ./source4/param/pyparam_util.c 2012-01-12 19:37:26.501392786 +0200
+@@ -21,7 +21,7 @@
+ #include "includes.h"
+ #include "param/param.h"
+ #include "param/loadparm.h"
+-#include "pytalloc.h"
++#include "lib/talloc/pytalloc.h"
+
+ #define PyLoadparmContext_AsLoadparmContext(obj) py_talloc_get_type(obj, struct loadparm_context)
+