aboutsummaryrefslogtreecommitdiffstats
path: root/net/samba41/Makefile
diff options
context:
space:
mode:
authortimur <timur@FreeBSD.org>2014-08-03 08:43:21 +0800
committertimur <timur@FreeBSD.org>2014-08-03 08:43:21 +0800
commit1bf87f314e130fbe845e61e4643155047d2eae65 (patch)
tree71045c04dea2aaafb002078e31f87f76f0ccfeac /net/samba41/Makefile
parent1ac33ee41e1579eb39acc3ee35ce872522e416fb (diff)
downloadfreebsd-ports-gnome-1bf87f314e130fbe845e61e4643155047d2eae65.tar.gz
freebsd-ports-gnome-1bf87f314e130fbe845e61e4643155047d2eae65.tar.zst
freebsd-ports-gnome-1bf87f314e130fbe845e61e4643155047d2eae65.zip
Upgrade ports to address CVE-2014-3560.
Security: CVE-2014-3560
Diffstat (limited to 'net/samba41/Makefile')
-rw-r--r--net/samba41/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/net/samba41/Makefile b/net/samba41/Makefile
index 0370677e560e..82f3751ec99d 100644
--- a/net/samba41/Makefile
+++ b/net/samba41/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= ${SAMBA4_BASENAME}41
PORTVERSION?= ${SAMBA4_VERSION}
-PORTREVISION?= 2
+PORTREVISION?= 0
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SAMBA}
MASTER_SITE_SUBDIR= samba/stable samba/rc
@@ -18,7 +18,7 @@ CONFLICTS?= *samba3[2-6]-3.* samba4-4.0.*
SAMBA4_BASENAME= samba
SAMBA4_PORTNAME= ${SAMBA4_BASENAME}4
-SAMBA4_VERSION= 4.1.9
+SAMBA4_VERSION= 4.1.11
SAMBA4_DISTNAME= ${SAMBA4_BASENAME}-${SAMBA4_VERSION:S|.p|pre|:S|.r|rc|:S|.t|tp|:S|.a|alpha|}
WRKSRC?= ${WRKDIR}/${DISTNAME}
@@ -106,8 +106,8 @@ BUILD_DEPENDS+= ntdb>=1.0:${PORTSDIR}/databases/ntdb
RUN_DEPENDS+= ntdb>=1.0:${PORTSDIR}/databases/ntdb
SAMBA4_BUNDLED_LIBS+= !ntdb
# ldb
-BUILD_DEPENDS+= ldb>=1.1.15:${PORTSDIR}/databases/ldb
-RUN_DEPENDS+= ldb>=1.1.15:${PORTSDIR}/databases/ldb
+BUILD_DEPENDS+= ldb>=1.1.17:${PORTSDIR}/databases/ldb
+RUN_DEPENDS+= ldb>=1.1.17:${PORTSDIR}/databases/ldb
SAMBA4_BUNDLED_LIBS+= !ldb
# Don't use external libcom_err
SAMBA4_BUNDLED_LIBS+= com_err
@@ -134,6 +134,7 @@ UTMP_DESC= UTMP accounting support
OPTIONS_DEFINE+= DEVELOPER MANPAGES EXP_MODULES
DEVELOPER_DESC= With development support
+MANPAGES_DESC= Build manpages from DOCBOOK templates
OPTIONS_SINGLE= DNS
OPTIONS_SINGLE_DNS= NSUPDATE BIND98 BIND99
@@ -183,7 +184,7 @@ CONFIGURE_ARGS+= --enable-debug
# https://bugzilla.samba.org/show_bug.cgi?id=8969
.if ${PORT_OPTIONS:MDEVELOPER}
-GDB_CMD?= gdb761
+GDB_CMD?= gdb771
BUILD_DEPENDS+= ${GDB_CMD}:${PORTSDIR}/devel/gdb
RUN_DEPENDS+= ${GDB_CMD}:${PORTSDIR}/devel/gdb
SAMBA4_MODULES+= auth_skel perfcount_test pdb_test vfs_shadow_copy_test vfs_skel_opaque vfs_skel_transparent vfs_fake_acls