aboutsummaryrefslogtreecommitdiffstats
path: root/net/samba
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-08-18 22:10:03 +0800
committerdinoex <dinoex@FreeBSD.org>2004-08-18 22:10:03 +0800
commit2a97bbb609660367d6623c2d9661786ea5d025e5 (patch)
tree865907b4e6b1c8f2b806262afd4ab20b7e466f7a /net/samba
parente0d8abb716d362ea081b11fb6572b43848b769b6 (diff)
downloadfreebsd-ports-gnome-2a97bbb609660367d6623c2d9661786ea5d025e5.tar.gz
freebsd-ports-gnome-2a97bbb609660367d6623c2d9661786ea5d025e5.tar.zst
freebsd-ports-gnome-2a97bbb609660367d6623c2d9661786ea5d025e5.zip
- workaround "Change Passwort" GID problem
PR: 52859, 60361 Submitted by: Jean Milanez Melo
Diffstat (limited to 'net/samba')
-rw-r--r--net/samba/Makefile1
-rw-r--r--net/samba/files/patch-util_sec.c15
2 files changed, 16 insertions, 0 deletions
diff --git a/net/samba/Makefile b/net/samba/Makefile
index c04b1184d90c..7653f9dd9362 100644
--- a/net/samba/Makefile
+++ b/net/samba/Makefile
@@ -7,6 +7,7 @@
PORTNAME= samba
PORTVERSION= 2.2.11
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SAMBA}
MASTER_SITE_SUBDIR= . old-versions
diff --git a/net/samba/files/patch-util_sec.c b/net/samba/files/patch-util_sec.c
new file mode 100644
index 000000000000..a49ddcc6a8bf
--- /dev/null
+++ b/net/samba/files/patch-util_sec.c
@@ -0,0 +1,15 @@
+*** source/lib/util_sec.c Wed Jul 17 15:47:49 2002
+--- source/lib/util_sec.c.neu Mon Jun 2 15:30:43 2003
+***************
+*** 112,119 ****
+--- 112,121 ----
+ (int)rgid, (int)egid,
+ (int)getgid(), (int)getegid(),
+ (int)getuid(), (int)geteuid()));
++ #if 0
+ smb_panic("failed to set gid\n");
+ exit(1);
++ #endif
+ }
+ }
+ }