aboutsummaryrefslogtreecommitdiffstats
path: root/net/sdl_net
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-02-27 20:38:47 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-02-27 20:38:47 +0800
commit07632498cee8692de4c5acb29558b14041059c70 (patch)
treee764205ba83f2bf799aaeeeb68be4ac6653708d4 /net/sdl_net
parentf9f105fdffb065359f3af851196d495319c2ce26 (diff)
downloadfreebsd-ports-gnome-07632498cee8692de4c5acb29558b14041059c70.tar.gz
freebsd-ports-gnome-07632498cee8692de4c5acb29558b14041059c70.tar.zst
freebsd-ports-gnome-07632498cee8692de4c5acb29558b14041059c70.zip
- Add LICENSE_FILE
- Regenerate patches
Diffstat (limited to 'net/sdl_net')
-rw-r--r--net/sdl_net/Makefile1
-rw-r--r--net/sdl_net/files/patch-SDLnetsys.h10
2 files changed, 6 insertions, 5 deletions
diff --git a/net/sdl_net/Makefile b/net/sdl_net/Makefile
index c66e87c1168b..72987f910f4b 100644
--- a/net/sdl_net/Makefile
+++ b/net/sdl_net/Makefile
@@ -12,6 +12,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Small sample cross-platform networking library
LICENSE= ZLIB
+LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
diff --git a/net/sdl_net/files/patch-SDLnetsys.h b/net/sdl_net/files/patch-SDLnetsys.h
index db99084f9e97..870a5394e7ad 100644
--- a/net/sdl_net/files/patch-SDLnetsys.h
+++ b/net/sdl_net/files/patch-SDLnetsys.h
@@ -1,8 +1,8 @@
---- SDLnetsys.h.orig Sun Jul 2 02:28:47 2000
-+++ SDLnetsys.h Wed Sep 20 18:42:27 2000
-@@ -41,6 +41,11 @@
- #include <unistd.h>
+--- SDLnetsys.h.orig 2012-01-15 16:20:10 UTC
++++ SDLnetsys.h
+@@ -54,6 +54,11 @@ typedef int socklen_t;
#include <fcntl.h>
+ #include <netinet/in.h>
#ifndef __BEOS__
+#ifdef __FreeBSD__
+#include <sys/types.h>
@@ -11,4 +11,4 @@
+#endif /* FreeBSD */
#include <arpa/inet.h>
#endif
- #include <netinet/in.h>
+ #ifdef linux /* FIXME: what other platforms have this? */