aboutsummaryrefslogtreecommitdiffstats
path: root/net/sendfile/pkg-plist
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1998-02-25 04:28:17 +0800
committersteve <steve@FreeBSD.org>1998-02-25 04:28:17 +0800
commit1f019a27061bcca36dadaa584b2d5cbd18e4fc8a (patch)
tree09d2319bf77c60bf574b93f5e6cafd90aa6d16ba /net/sendfile/pkg-plist
parent7245e57ff361fdd33a4b57db646a1d484adc6a42 (diff)
downloadfreebsd-ports-gnome-1f019a27061bcca36dadaa584b2d5cbd18e4fc8a.tar.gz
freebsd-ports-gnome-1f019a27061bcca36dadaa584b2d5cbd18e4fc8a.tar.zst
freebsd-ports-gnome-1f019a27061bcca36dadaa584b2d5cbd18e4fc8a.zip
Simple Asynchronous File Transfer Reference Implementation.
PR: 4664 Submitted by: Stefan Zehl <sec@42.org>
Diffstat (limited to 'net/sendfile/pkg-plist')
-rw-r--r--net/sendfile/pkg-plist25
1 files changed, 25 insertions, 0 deletions
diff --git a/net/sendfile/pkg-plist b/net/sendfile/pkg-plist
new file mode 100644
index 000000000000..8179f34db054
--- /dev/null
+++ b/net/sendfile/pkg-plist
@@ -0,0 +1,25 @@
+bin/check_sendfile
+bin/receive
+bin/sendfile
+bin/sendmsg
+bin/sf_cleanup
+bin/utf7decode
+bin/utf7encode
+etc/sendfile.cf
+etc/sendfile.deny
+sbin/sendfiled
+man/man1/receive.1.gz
+man/man1/sendfile.1.gz
+man/man1/sendmsg.1.gz
+@exec mkdir -p /var/spool/sendfile/OUTGOING /var/spool/sendfile/LOG
+@exec chmod 755 /var/spool/sendfile
+@exec chmod 1777 /var/spool/sendfile/OUTGOING
+@exec chmod 700 /var/spool/sendfile/LOG
+@exec touch /var/spool/sendfile/LOG/in /var/spool/sendfile/LOG/out
+@exec chmod 600 /var/spool/sendfile/LOG/in /var/spool/sendfile/LOG/out
+@exec echo -e 'saft\tstream\ttcp\tnowait\troot\t/usr/local/sbin/sendfiled sendfiled' >> /etc/inetd.conf
+@exec echo -e 'saft\t\t487/tcp\t# simple asynchronous file transfer'>>/etc/services
+@exec kill -HUP `ps auxw|awk '$11 == "inetd" { print $2 } '`
+@unexec perl -pi.bak -e '/^saft/ && ($_="")' /etc/inetd.conf
+@unexec kill -HUP `ps auxw|awk '$11 == "inetd" { print $2 } '`
+@unexec rm -R /var/spool/sendfile