aboutsummaryrefslogtreecommitdiffstats
path: root/net/ser
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2005-03-15 16:54:51 +0800
committerMaxim Sobolev <sobomax@FreeBSD.org>2005-03-15 16:54:51 +0800
commit3bd1905091185fcd36847511efb9fa0018a1c36e (patch)
treefc0281cd15add009e9aee33996be77d45d338a96 /net/ser
parentd038538a07717d6176cbafc0cfb359086d1759f9 (diff)
downloadfreebsd-ports-gnome-3bd1905091185fcd36847511efb9fa0018a1c36e.tar.gz
freebsd-ports-gnome-3bd1905091185fcd36847511efb9fa0018a1c36e.tar.zst
freebsd-ports-gnome-3bd1905091185fcd36847511efb9fa0018a1c36e.zip
Fix possible coredump in usrloc module (backported from soon to be released
0.9.0. Reported by: Barry Murphy <barry@unix.co.nz>
Diffstat (limited to 'net/ser')
-rw-r--r--net/ser/Makefile1
-rw-r--r--net/ser/files/patch-modules::usrloc::udomain.c14
2 files changed, 15 insertions, 0 deletions
diff --git a/net/ser/Makefile b/net/ser/Makefile
index b2f3c863ec5f..05bc382dfadd 100644
--- a/net/ser/Makefile
+++ b/net/ser/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ser
PORTVERSION= 0.8.14
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.berlios.de/pub/ser/${PORTVERSION}/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}_src
diff --git a/net/ser/files/patch-modules::usrloc::udomain.c b/net/ser/files/patch-modules::usrloc::udomain.c
new file mode 100644
index 000000000000..3e627f8ef7eb
--- /dev/null
+++ b/net/ser/files/patch-modules::usrloc::udomain.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- modules/usrloc/udomain.c
++++ modules/usrloc/udomain.c
+@@ -288,7 +288,7 @@
+ }
+ flags = VAL_BITMAP(ROW_VALUES(row) + 8);
+ ua.s = (char*)VAL_STRING(ROW_VALUES(row) + 9);
+- ua.len = strlen(ua.s);
++ ua.len = (ua.s != NULL) ? strlen(ua.s) : 0;
+
+ if (use_domain) {
+ domain = (char*)VAL_STRING(ROW_VALUES(row) + 10);