aboutsummaryrefslogtreecommitdiffstats
path: root/net/service-discovery-applet/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-05-07 07:09:26 +0800
committermarcus <marcus@FreeBSD.org>2006-05-07 07:09:26 +0800
commite55c73caffc1ff0d764eca30c8faa2969492c320 (patch)
tree65a3e85fcb5f619bb87dae633f980bab8ad7df0e /net/service-discovery-applet/Makefile
parenta3335866d70ac77926990d465cca20393cd3eac9 (diff)
downloadfreebsd-ports-gnome-e55c73caffc1ff0d764eca30c8faa2969492c320.tar.gz
freebsd-ports-gnome-e55c73caffc1ff0d764eca30c8faa2969492c320.tar.zst
freebsd-ports-gnome-e55c73caffc1ff0d764eca30c8faa2969492c320.zip
Add service-discovery-applet, a GNOME applet for viewing available network
services advertised via mDNS (aka Bonjour, Zeroconf, Rendezvous).
Diffstat (limited to 'net/service-discovery-applet/Makefile')
-rw-r--r--net/service-discovery-applet/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/net/service-discovery-applet/Makefile b/net/service-discovery-applet/Makefile
new file mode 100644
index 000000000000..2807eed23f37
--- /dev/null
+++ b/net/service-discovery-applet/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: service-discovery-applet
+# Date Created: 06 May 2006
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom$
+#
+
+PORTNAME= service-discovery-applet
+PORTVERSION= 0.4.1
+CATEGORIES= net dns gnome
+MASTER_SITES= http://0pointer.de/~sebest/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A GNOME applet that shows available network services using mDNS
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/avahi/__init__.py:${PORTSDIR}/net/py-avahi
+RUN_DEPENDS= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/avahi/__init__.py:${PORTSDIR}/net/py-avahi
+
+USE_X_PREFIX= yes
+USE_GETTEXT= yes
+USE_PYTHON= yes
+USE_GNOME= gnomehack gnomeprefix intlhack pygnomedesktop
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS= service-discovery-applet.schemas
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/plugins/gconfterminal.py
+
+post-install:
+ @${X11BASE}/bin/gtk-update-icon-cache -f -q --ignore-theme-index \
+ ${PREFIX}/share/gnome/service-discovery-applet/icons
+
+.include <bsd.port.mk>