aboutsummaryrefslogtreecommitdiffstats
path: root/net/shmux/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-03-06 01:07:43 +0800
committermiwi <miwi@FreeBSD.org>2013-03-06 01:07:43 +0800
commitb5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7 (patch)
tree268d74f9d8738f78b0c895672044611aa6343387 /net/shmux/Makefile
parent4c148339a17778393b116c6e7051a9bc484e786a (diff)
downloadfreebsd-ports-gnome-b5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7.tar.gz
freebsd-ports-gnome-b5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7.tar.zst
freebsd-ports-gnome-b5e88d7789bddf1e308d47c8c5b81b8d3f0c31d7.zip
- Convert to OptionsNG
- Trim header Reviewed by: beat, bapt, kwm
Diffstat (limited to 'net/shmux/Makefile')
-rw-r--r--net/shmux/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/net/shmux/Makefile b/net/shmux/Makefile
index 3af1e252f517..2ead14b6b299 100644
--- a/net/shmux/Makefile
+++ b/net/shmux/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: shmux
-# Date created: 2 September 2004
-# Whom: jamundsen
-#
+# Created by: jamundsen
# $FreeBSD$
-#
PORTNAME= shmux
DISTVERSION= 1.0.2
@@ -15,8 +11,9 @@ EXTRACT_SUFX= .tgz
MAINTAINER= online@jamundsen.dyndns.org
COMMENT= Utility to run commands on multiple hosts using shell commands
-OPTIONS= FPING "Use fping utility" on \
- PCRE "Use perl regular expressions library" off
+OPTIONS_DEFINE= FPING PCRE
+OPTIONS_DEFAULT= FPING
+FPING_DESC= Use fping utility
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --datadir=${PREFIX}/share/examples
@@ -26,17 +23,17 @@ ALL_TARGET= ${PORTNAME}
MAN1= shmux.1
MANCOMPRESSED= no
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_FPING)
+.if ${PORT_OPTIONS:MFPING}
RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
.endif
-.if defined(WITH_PCRE)
+.if ${PORT_OPTIONS:MPCRE}
LIB_DEPENDS+= pcre.3:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS+= --with-pcre=${LOCALBASE}/lib
.else
CONFIGURE_ARGS+= --with-pcre=no
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>