aboutsummaryrefslogtreecommitdiffstats
path: root/net/silky
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-03 23:05:37 +0800
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-03 23:05:37 +0800
commit4bad1a7b6ef25f385e1b187ba3d1424555df3364 (patch)
tree21e2efd99dc6c3a3fbca167050aadfd596921810 /net/silky
parent5d3ed5c36abb6f3e1ee339734ceb946e487bec49 (diff)
downloadfreebsd-ports-gnome-4bad1a7b6ef25f385e1b187ba3d1424555df3364.tar.gz
freebsd-ports-gnome-4bad1a7b6ef25f385e1b187ba3d1424555df3364.tar.zst
freebsd-ports-gnome-4bad1a7b6ef25f385e1b187ba3d1424555df3364.zip
Add silky 0.4.2, a simple and easy to use graphical,
os-independent SILC client. Silky is intended to contain all necessary features of a SILC client, while keeping the UI as simple and clean as possible. PR: 60849 Submitted by: Evgueni V. Gavrilov <aquatique@rusunix.org>
Diffstat (limited to 'net/silky')
-rw-r--r--net/silky/Makefile40
-rw-r--r--net/silky/distinfo1
-rw-r--r--net/silky/pkg-descr6
-rw-r--r--net/silky/pkg-plist23
4 files changed, 70 insertions, 0 deletions
diff --git a/net/silky/Makefile b/net/silky/Makefile
new file mode 100644
index 000000000000..54f9aca59863
--- /dev/null
+++ b/net/silky/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: silky
+# Date created: 2003.12.16
+# Whom: Evgueni V. Gavrilov <aquatique@rusunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= silky
+PORTVERSION= 0.4.2
+CATEGORIES= net security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ ftp://rusunix.org/pub/FreeBSD/distfiles/
+MASTER_SITE_SUBDIR= silky
+
+MAINTAINER= aquatique@rusunix.org
+COMMENT= A simple and easy to use graphical, os-independent SILC client
+
+LIB_DEPENDS= silcclient-1.0.2:${PORTSDIR}/devel/silc-toolkit
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-silc-includes=${LOCALBASE}/include/silc \
+ --with-silc-libs=${LOCALBASE}/lib \
+ --with-docdir=${DOCSDIR}
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -liconv ${PTHREAD_LIBS}"
+CFLAGS+= ${PTHREAD_CFLAGS}
+
+USE_GNOME= gtk20
+USE_GMAKE= yes
+USE_PERL5= yes
+USE_X_PREFIX= yes
+
+post-patch:
+ @${PERL} -pi -e 's/ include / /' ${WRKSRC}/Makefile.in
+ @${PERL} -pi -e 's|/etc/|${LOCALBASE}/etc/|' ${WRKSRC}/src/main.c
+ @${PERL} -pi -e 's|share/pixmaps/\$${\w+}|share/pixmaps/|; \
+ s|(PACKAGE_PIXMAPS_DIR \")\$${packageprefix}/|\1${X11BASE}/|' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/net/silky/distinfo b/net/silky/distinfo
new file mode 100644
index 000000000000..4260052e5bb5
--- /dev/null
+++ b/net/silky/distinfo
@@ -0,0 +1 @@
+MD5 (silky-0.4.2.tar.gz) = 71de654fdbb73e01ffb39aaf30ac0cce
diff --git a/net/silky/pkg-descr b/net/silky/pkg-descr
new file mode 100644
index 000000000000..358691653deb
--- /dev/null
+++ b/net/silky/pkg-descr
@@ -0,0 +1,6 @@
+Silky is a simple and easy to use graphical, os-independent SILC client.
+
+Silky is intended to contain all necessary features of a SILC client,
+while keeping the UI as simple and clean as possible.
+
+WWW: http://silky.sourceforge.net
diff --git a/net/silky/pkg-plist b/net/silky/pkg-plist
new file mode 100644
index 000000000000..07f404261e31
--- /dev/null
+++ b/net/silky/pkg-plist
@@ -0,0 +1,23 @@
+bin/silky
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+share/pixmaps/silky_icon.png
+share/silky/silky.glade
+share/silky/silky-channel.glade
+share/silky/silky-channel-label.glade
+share/silky/silky-query.glade
+share/silky/silky-query-label.glade
+share/locale/de/LC_MESSAGES/silky.mo
+share/locale/fi/LC_MESSAGES/silky.mo
+share/locale/it/LC_MESSAGES/silky.mo
+share/locale/sk/LC_MESSAGES/silky.mo
+share/locale/ru/LC_MESSAGES/silky.mo
+share/gnome/apps/Applications/silky.desktop
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@unexec rmdir %D/share/pixmaps 2>/dev/null || true
+@dirrm share/silky