aboutsummaryrefslogtreecommitdiffstats
path: root/net/sipxcalllib
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-02-02 06:40:34 +0800
committermiwi <miwi@FreeBSD.org>2007-02-02 06:40:34 +0800
commit06f6f80c9aa358198eb2fa40ffc53e5e6b658b72 (patch)
tree59a57ea8b8511dba8e9cb1eb6170da1686a2fd2e /net/sipxcalllib
parentfd2c2ed4d12d53faff105cb028c5a1ec03c8a90b (diff)
downloadfreebsd-ports-gnome-06f6f80c9aa358198eb2fa40ffc53e5e6b658b72.tar.gz
freebsd-ports-gnome-06f6f80c9aa358198eb2fa40ffc53e5e6b658b72.tar.zst
freebsd-ports-gnome-06f6f80c9aa358198eb2fa40ffc53e5e6b658b72.zip
sipXcalllib is a library that handles call signaling. It is a
necessary dependancy of the sipX project. WWW: http://sipx-wiki.calivia.com/index.php/Main_Page PR: ports/107931 Submitted by: Michael Durian <durian at shadetreesoftware.com>
Diffstat (limited to 'net/sipxcalllib')
-rw-r--r--net/sipxcalllib/Makefile36
-rw-r--r--net/sipxcalllib/distinfo3
-rw-r--r--net/sipxcalllib/files/patch-doc-Makefile.am11
-rw-r--r--net/sipxcalllib/files/patch-doc-Makefile.in11
-rw-r--r--net/sipxcalllib/pkg-descr4
-rw-r--r--net/sipxcalllib/pkg-plist138
6 files changed, 203 insertions, 0 deletions
diff --git a/net/sipxcalllib/Makefile b/net/sipxcalllib/Makefile
new file mode 100644
index 000000000000..1fa899229fd3
--- /dev/null
+++ b/net/sipxcalllib/Makefile
@@ -0,0 +1,36 @@
+# Ports collection makefile for: sipxcalllib
+# Date created: Jan 8, 2007
+# Whom: Michael Durian <durian@shadetreesoftware.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sipxcalllib
+PORTVERSION= 3.6.0
+CATEGORIES= net
+MASTER_SITES= http://www.sipfoundry.org/pub/sipX/3.6/SRC/
+
+MAINTAINER= durian@shadetreesoftware.com
+COMMENT= sipX library for call handling
+
+BUILD_DEPENDS= ginstall:${PORTSDIR}/sysutils/coreutils \
+ cppunit-config:${PORTSDIR}/devel/cppunit
+LIB_DEPENDS= sipXport:${PORTSDIR}/net/sipxportlib \
+ sipXtack:${PORTSDIR}/net/sipxtacklib \
+ sipXmedia:${PORTSDIR}/net/sipxmedialib \
+ sipXmediaProcessing:${PORTSDIR}/net/sipxmediaadapterlib \
+ pcre.0:${PORTSDIR}/devel/pcre
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= autoconf:259:env automake:19:env
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+LOCALSTATEDIR=${DESTDIR}/var
+CONFIGURE_ENV+= wwwdir=${PREFIX}/www/sipX \
+ INSTALL=`which ginstall`
+CONFIGURE_ARGS+= --enable-sip-tls \
+ --prefix=${PREFIX} \
+ --localstatedir=${LOCALSTATEDIR}
+
+.include <bsd.port.mk>
diff --git a/net/sipxcalllib/distinfo b/net/sipxcalllib/distinfo
new file mode 100644
index 000000000000..75a97a636059
--- /dev/null
+++ b/net/sipxcalllib/distinfo
@@ -0,0 +1,3 @@
+MD5 (sipxcalllib-3.6.0.tar.bz2) = 31253be01d966a071c5a4050cb81cd41
+SHA256 (sipxcalllib-3.6.0.tar.bz2) = 55f5d34193f843d3cad95748112d00102ba4b1301ce966cae9e9f2da12d0ad0a
+SIZE (sipxcalllib-3.6.0.tar.bz2) = 767043
diff --git a/net/sipxcalllib/files/patch-doc-Makefile.am b/net/sipxcalllib/files/patch-doc-Makefile.am
new file mode 100644
index 000000000000..2b99f0444ae8
--- /dev/null
+++ b/net/sipxcalllib/files/patch-doc-Makefile.am
@@ -0,0 +1,11 @@
+--- doc/Makefile.am.orig Mon Jan 29 14:27:27 2007
++++ doc/Makefile.am Mon Jan 29 14:29:04 2007
+@@ -29,7 +29,7 @@
+ rm -rf $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ @INSTALL@ -d $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ find @PACKAGE@ -type f -print \
+- | xargs -i% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
++ | xargs -I% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
+
+ clean: clean-doc
+
diff --git a/net/sipxcalllib/files/patch-doc-Makefile.in b/net/sipxcalllib/files/patch-doc-Makefile.in
new file mode 100644
index 000000000000..7fc070a14669
--- /dev/null
+++ b/net/sipxcalllib/files/patch-doc-Makefile.in
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orig Mon Jan 29 14:27:18 2007
++++ doc/Makefile.in Mon Jan 29 14:29:14 2007
+@@ -495,7 +495,7 @@
+ rm -rf $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ @INSTALL@ -d $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ find @PACKAGE@ -type f -print \
+- | xargs -i% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
++ | xargs -I% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
+
+ clean: clean-doc
+
diff --git a/net/sipxcalllib/pkg-descr b/net/sipxcalllib/pkg-descr
new file mode 100644
index 000000000000..9aa51537b251
--- /dev/null
+++ b/net/sipxcalllib/pkg-descr
@@ -0,0 +1,4 @@
+sipXcalllib is a library that handles call signaling. It is a
+necessary dependancy of the sipX project.
+
+WWW: http://sipx-wiki.calivia.com/index.php/Main_Page
diff --git a/net/sipxcalllib/pkg-plist b/net/sipxcalllib/pkg-plist
new file mode 100644
index 000000000000..ca49eb0e702b
--- /dev/null
+++ b/net/sipxcalllib/pkg-plist
@@ -0,0 +1,138 @@
+bin/sipxcalllib-config
+include/cp/CallManager.h
+include/cp/Connection.h
+include/cp/CpCall.h
+include/cp/CpCallManager.h
+include/cp/CpGatewayManager.h
+include/cp/CpGhostConnection.h
+include/cp/CpIntMessage.h
+include/cp/CpMultiStringMessage.h
+include/cp/CpPeerCall.h
+include/cp/CpStringMessage.h
+include/cp/DialogEventPublisher.h
+include/cp/LinePresenceBase.h
+include/cp/LinePresenceMonitor.h
+include/cp/PresenceDialInServer.h
+include/cp/SipConnection.h
+include/cp/SipPresenceMonitor.h
+include/ps/PsButtonId.h
+include/ps/PsButtonInfo.h
+include/ps/PsButtonTask.h
+include/ps/PsHookswDev.h
+include/ps/PsHookswTask.h
+include/ps/PsKeybdDev.h
+include/ps/PsLampDev.h
+include/ps/PsLampId.h
+include/ps/PsLampInfo.h
+include/ps/PsLampTask.h
+include/ps/PsMsg.h
+include/ps/PsPhoneTask.h
+include/ps/PsTaoButton.h
+include/ps/PsTaoComponent.h
+include/ps/PsTaoComponentGroup.h
+include/ps/PsTaoDisplay.h
+include/ps/PsTaoHookswitch.h
+include/ps/PsTaoLamp.h
+include/ps/PsTaoMicrophone.h
+include/ps/PsTaoRinger.h
+include/ps/PsTaoSpeaker.h
+include/ps/linux/PsHookswDevLinux.h
+include/ps/linux/PsKeybdDevLinux.h
+include/ps/linux/PsLampDevLinux.h
+include/ps/wnt/PsHookswDevWnt.h
+include/ps/wnt/PsKeybdDevWnt.h
+include/ps/wnt/PsLampDevWnt.h
+include/ptapi/PtAddessCapabilities.h
+include/ptapi/PtAddress.h
+include/ptapi/PtAddressEvent.h
+include/ptapi/PtAddressForwarding.h
+include/ptapi/PtAddressListener.h
+include/ptapi/PtAudioCodec.h
+include/ptapi/PtCall.h
+include/ptapi/PtCallCapabilities.h
+include/ptapi/PtCallEvent.h
+include/ptapi/PtCallListener.h
+include/ptapi/PtComponent.h
+include/ptapi/PtComponentGroup.h
+include/ptapi/PtComponentGroupCapabilities.h
+include/ptapi/PtComponentIntChangeEvent.h
+include/ptapi/PtComponentStringChangeEvent.h
+include/ptapi/PtConfigDb.h
+include/ptapi/PtConnection.h
+include/ptapi/PtConnectionCapabilities.h
+include/ptapi/PtConnectionEvent.h
+include/ptapi/PtConnectionListener.h
+include/ptapi/PtDefs.h
+include/ptapi/PtEvent.h
+include/ptapi/PtEventListener.h
+include/ptapi/PtEventMask.h
+include/ptapi/PtGatewayInterface.h
+include/ptapi/PtMediaCapabilities.h
+include/ptapi/PtMetaEvent.h
+include/ptapi/PtMultiCallEvent.h
+include/ptapi/PtMultiCallMetaEvent.h
+include/ptapi/PtPhoneButton.h
+include/ptapi/PtPhoneDisplay.h
+include/ptapi/PtPhoneExtSpeaker.h
+include/ptapi/PtPhoneGraphicDisplay.h
+include/ptapi/PtPhoneHookswitch.h
+include/ptapi/PtPhoneLamp.h
+include/ptapi/PtPhoneMicrophone.h
+include/ptapi/PtPhoneRinger.h
+include/ptapi/PtPhoneSpeaker.h
+include/ptapi/PtPhoneTerminal.h
+include/ptapi/PtPhoneTextDisplay.h
+include/ptapi/PtProvider.h
+include/ptapi/PtProviderCapabilities.h
+include/ptapi/PtProviderEvent.h
+include/ptapi/PtProviderListener.h
+include/ptapi/PtSessionDesc.h
+include/ptapi/PtSingleCallMetaEvent.h
+include/ptapi/PtTerminal.h
+include/ptapi/PtTerminalCapabilities.h
+include/ptapi/PtTerminalComponentEvent.h
+include/ptapi/PtTerminalComponentListener.h
+include/ptapi/PtTerminalConnection.h
+include/ptapi/PtTerminalConnectionCapabilities.h
+include/ptapi/PtTerminalConnectionEvent.h
+include/ptapi/PtTerminalConnectionListener.h
+include/ptapi/PtTerminalEvent.h
+include/ptapi/PtTerminalListener.h
+include/tao/TaoAdaptor.h
+include/tao/TaoAddressAdaptor.h
+include/tao/TaoCallAdaptor.h
+include/tao/TaoClientTask.h
+include/tao/TaoConnectionAdaptor.h
+include/tao/TaoDefs.h
+include/tao/TaoEvent.h
+include/tao/TaoEventDispatcher.h
+include/tao/TaoEventListener.h
+include/tao/TaoListenerClient.h
+include/tao/TaoListenerEventMessage.h
+include/tao/TaoListenerManager.h
+include/tao/TaoListeningTask.h
+include/tao/TaoMessage.h
+include/tao/TaoObject.h
+include/tao/TaoObjectMap.h
+include/tao/TaoPhoneComponentAdaptor.h
+include/tao/TaoProviderAdaptor.h
+include/tao/TaoProviderListener.h
+include/tao/TaoReference.h
+include/tao/TaoServerTask.h
+include/tao/TaoString.h
+include/tao/TaoTerminalAdaptor.h
+include/tao/TaoTerminalConnectionAdaptor.h
+include/tao/TaoTerminalConnectionListener.h
+include/tao/TaoTransportAgent.h
+include/tao/TaoTransportTask.h
+lib/libsipXcall.a
+lib/libsipXcall.la
+lib/libsipXcall.so
+lib/libsipXcall.so.1
+@dirrm include/tapi
+@dirrm include/tao
+@dirrm include/ptapi
+@dirrm include/ps/wnt
+@dirrm include/ps/linux
+@dirrm include/ps
+@dirrm include/cp