aboutsummaryrefslogtreecommitdiffstats
path: root/net/sipxvxml
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-27 16:29:17 +0800
committermiwi <miwi@FreeBSD.org>2007-03-27 16:29:17 +0800
commit1b65266ade81caeccc6a6212f4aee213573f74d6 (patch)
treee266a3aeabdff0d836374c62cb343f8421f2451b /net/sipxvxml
parent2a8e035d3bcdbe19031962c31f855f0f932aa184 (diff)
downloadfreebsd-ports-gnome-1b65266ade81caeccc6a6212f4aee213573f74d6.tar.gz
freebsd-ports-gnome-1b65266ade81caeccc6a6212f4aee213573f74d6.tar.zst
freebsd-ports-gnome-1b65266ade81caeccc6a6212f4aee213573f74d6.zip
sipxvxml should change the ownership, if necessary, of files and directories
it installs. Perviously, the toplevel port, sipxpbx, changed ownership for not only its files, but all the dependant ports too. - Bump PORTREVISION Submitted by: Mike Durian <durian@shadetreesoftware.com>
Diffstat (limited to 'net/sipxvxml')
-rw-r--r--net/sipxvxml/Makefile13
-rw-r--r--net/sipxvxml/files/pkg-install.in38
2 files changed, 49 insertions, 2 deletions
diff --git a/net/sipxvxml/Makefile b/net/sipxvxml/Makefile
index 779225817b42..0c146444d5f5 100644
--- a/net/sipxvxml/Makefile
+++ b/net/sipxvxml/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sipxvxml
PORTVERSION= 3.6.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.sipfoundry.org/pub/sipX/3.6/SRC/
@@ -34,10 +35,18 @@ CONFIGURE_ENV+= wwwdir=${PREFIX}/www/sipX \
CONFIGURE_ARGS+= --enable-sip-tls \
--prefix=${PREFIX} \
--localstatedir=${LOCALSTATEDIR}
-SUB_LIST= LOCALSTATEDIR=${LOCALSTATEDIR}
-SUB_FILES= pkg-deinstall
+SUB_LIST= LOCALSTATEDIR=${LOCALSTATEDIR} \
+ PREFIX=${PREFIX}
+SUB_FILES= pkg-install pkg-deinstall
+PKGINSTALL= ${WRKDIR}/pkg-install
post-patch:
@${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipXvxml.sh.in
+pre-install:
+ @${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
+
+post-install:
+ @${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL
+
.include <bsd.port.mk>
diff --git a/net/sipxvxml/files/pkg-install.in b/net/sipxvxml/files/pkg-install.in
new file mode 100644
index 000000000000..be5585a14288
--- /dev/null
+++ b/net/sipxvxml/files/pkg-install.in
@@ -0,0 +1,38 @@
+#!/bin/sh
+
+PATH=/bin:/usr/sbin
+
+USER=sipx
+GROUP=sipx
+
+case $2 in
+PRE-INSTALL)
+ if pw group show "${GROUP}" 2> /dev/null ; then
+ echo "You already have a group \"${GROUP}\", so I will use it."
+ else
+ if pw groupadd ${GROUP} ; then
+ echo "Added group \"${GROUP}\"."
+ else
+ echo "Add of group \"${GROUP}\" failed."
+ exit 1
+ fi
+ fi
+
+ if pw user show "${USER}" 2> /dev/null ; then
+ echo "You already have a user \"${USER}\", so I will use it."
+ else
+ if pw useradd ${USER} -g ${GROUP} -h - \
+ -d %%LOCALSTATEDIR%%/sipxdata/configserver/phone/profile/tftproot -s %%PREFIX%%/bin/bash -c "sipX" ; then
+ echo "Added user \"${USER}\"."
+ else
+ echo "Add of user \"${USER}\" failed."
+ exit 1
+ fi
+ fi
+ ;;
+POST-INSTALL)
+ chown ${USER}:${GROUP} %%PREFIX%%/etc/sipxpbx
+ chown ${USER}:${GROUP} %%PREFIX%%/www/sipX/conf
+ chown ${USER}:${GROUP} %%PREFIX%%/www/sipX
+ ;;
+esac