aboutsummaryrefslogtreecommitdiffstats
path: root/net/smm++/files
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2002-01-23 06:13:49 +0800
committersf <sf@FreeBSD.org>2002-01-23 06:13:49 +0800
commit7f348f540c2446654a8068ff0c9c624b014a19da (patch)
treec409f5b3b1daeeff6ee662c7fa20199d730f2c96 /net/smm++/files
parent23528a2a85b26457b3f20f55c367f5cf041d7cc0 (diff)
downloadfreebsd-ports-gnome-7f348f540c2446654a8068ff0c9c624b014a19da.tar.gz
freebsd-ports-gnome-7f348f540c2446654a8068ff0c9c624b014a19da.tar.zst
freebsd-ports-gnome-7f348f540c2446654a8068ff0c9c624b014a19da.zip
update to 5.1.
change MASTER_SITES. PR: 34154 Submitted by: maintainer
Diffstat (limited to 'net/smm++/files')
-rw-r--r--net/smm++/files/patch-Makefile39
-rw-r--r--net/smm++/files/patch-itk.sh51
2 files changed, 11 insertions, 79 deletions
diff --git a/net/smm++/files/patch-Makefile b/net/smm++/files/patch-Makefile
index 288644e9fdb0..5d8168628261 100644
--- a/net/smm++/files/patch-Makefile
+++ b/net/smm++/files/patch-Makefile
@@ -1,15 +1,6 @@
---- /home/edwin/smm5r0/Install.unix/Makefile Fri Jun 15 07:05:56 2001
-+++ Makefile Sun Jul 15 19:20:06 2001
-@@ -12,7 +12,7 @@
- # usual unix environment (if you have root access).
- BIN=/usr/local/bin
- SRC=/usr/local/lib/smm
--DOC=/usr/local/doc/smm
-+DOC=/usr/local/share/doc/smm
-
- # --- If you don't have root access, you could choose to install
- # SMM++ locally in your home directory. Therefore use the
-@@ -60,6 +60,8 @@
+--- Makefile.orig Tue Jan 22 18:45:51 2002
++++ Makefile Tue Jan 22 18:46:40 2002
+@@ -58,6 +58,8 @@
# this Makefile. If you can read Makefiles, feel free
# to do whatever you like.
@@ -18,27 +9,3 @@
smm: Makefile
@echo "--- Building startup file."
@if [ -z ${ITKWISH} ] ; then \
-@@ -89,9 +91,9 @@
- install-src:
- @echo "--- Installing libraries to ${SRC}."
- @install -d ${SRC}
-- @cp -au ../sources/ ${SRC}
-- @cp -au ../images/ ${SRC}
-- @cp -au ../config/ ${SRC}
-+ @cp -Rp ../sources ${SRC}
-+ @cp -Rp ../images ${SRC}
-+ @cp -Rp ../config ${SRC}
- uninstall-src:
- @echo "--- Uninstalling libraries from ${SRC}."
- @rm -rf ${SRC}
-@@ -100,8 +102,8 @@
- @echo " Documentation is installed in ${DOC}."
- @echo " The html manual starts at file:${DOC}/man/index.html."
- @install -d ${DOC}
-- @cp -au ../docu/* ${DOC}
-- @cp -au ../man/ ${DOC}
-+ @cp -Rp ../docu/* ${DOC}
-+ @cp -Rp ../man/ ${DOC}
- uninstall-doc:
- @echo "--- Uninstalling documentation from ${DOC}."
- @rm -rf ${DOC}
diff --git a/net/smm++/files/patch-itk.sh b/net/smm++/files/patch-itk.sh
index 969ed2e4e253..3d83d0fbbc54 100644
--- a/net/smm++/files/patch-itk.sh
+++ b/net/smm++/files/patch-itk.sh
@@ -1,46 +1,11 @@
---- ../../smm5r0/Install.unix/itk.sh Mon Mar 19 08:46:07 2001
-+++ itk.sh Sun Jul 15 17:01:08 2001
-@@ -1,32 +1,16 @@
- #!/bin/sh
+--- itk.sh.orig Tue Jan 22 18:48:12 2002
++++ itk.sh Tue Jan 22 18:48:48 2002
+@@ -4,7 +4,7 @@
+ #
- # all possible itkwish executables
--itkarray=(itkwish3.1 itkwish3 itkwish30 itkwish)
+ # all possible itkwish executables
+-itkarray="itkwish3.1 itkwish3 itkwish30 itkwish3.0 itkwish"
+itkarray="itkwish3.1 itkwish3 itkwish30 itkwish3.0 itkwish wish8.3 wish8.2"
--# $PATH exploded as an array
--explode=(`echo $PATH | sed 's/:/ /g'`)
--
--element_count=${#explode[@]}
--i=0
--found=0
--while [ $i -lt ${element_count} ]
--do
-- second_count=${#itkarray[@]}
-- x=0
-- while [ $x -lt ${second_count} ]
-- do
-- if [ -x ${explode[$i]}/${itkarray[$x]} ]; then
-- smm=${explode[$i]}/${itkarray[$x]}
-- found=1
-- break
-- fi
-- let "x=$x + 1"
-- done
-- let "i = $i + 1"
-+set $itkarray
-+while [ ! -z "$1" ]; do
-+ smm=`which $1`
-+ if [ $? -eq 0 ]; then
-+ echo ${smm}
-+ exit 0
-+ fi
-+ shift
- done
--if [ ${found} -eq 1 ] ; then
-- echo ${smm}
-- exit 0
--else
-- exit 1
--fi
-+
-+exit 1
+ set $itkarray
+ while [ ! -z "$1" ]; do