aboutsummaryrefslogtreecommitdiffstats
path: root/net/squall
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2004-08-08 16:07:05 +0800
committerkuriyama <kuriyama@FreeBSD.org>2004-08-08 16:07:05 +0800
commit991d698c0f2f66a29fcc4d976cbf88aa24be6845 (patch)
treecea9c3af1297d9cf8d9813e25c806a1678c2fee7 /net/squall
parenta4b11627345c091457123b55561d012f111a2834 (diff)
downloadfreebsd-ports-gnome-991d698c0f2f66a29fcc4d976cbf88aa24be6845.tar.gz
freebsd-ports-gnome-991d698c0f2f66a29fcc4d976cbf88aa24be6845.tar.zst
freebsd-ports-gnome-991d698c0f2f66a29fcc4d976cbf88aa24be6845.zip
Add squall (renamed from pdtpd).
Diffstat (limited to 'net/squall')
-rw-r--r--net/squall/Makefile29
-rw-r--r--net/squall/distinfo2
-rw-r--r--net/squall/pkg-descr8
-rw-r--r--net/squall/pkg-plist8
4 files changed, 47 insertions, 0 deletions
diff --git a/net/squall/Makefile b/net/squall/Makefile
new file mode 100644
index 000000000000..94189f4f110c
--- /dev/null
+++ b/net/squall/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: squall
+# Date created: 5 Apr 2004
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= squall
+PORTVERSION= 0.1.20040808
+CATEGORIES= net
+MASTER_SITES= http://dist.bsdlab.org/
+DISTNAME= ${PORTNAME}-20040808
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Server for the Peer Distributed Transfer Protocol (PDTP)
+
+HAS_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+STRIP= # Keep empty for debugging.
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/squall/squall ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/squallhub/squallhub ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/squallproxy/squallproxy ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/squirt/squirt ${PREFIX}/sbin
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.txt ${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/net/squall/distinfo b/net/squall/distinfo
new file mode 100644
index 000000000000..a1faabdc1776
--- /dev/null
+++ b/net/squall/distinfo
@@ -0,0 +1,2 @@
+MD5 (squall-20040808.tar.gz) = 9b93a87933cff07896d4f58da9711e5b
+SIZE (squall-20040808.tar.gz) = 136670
diff --git a/net/squall/pkg-descr b/net/squall/pkg-descr
new file mode 100644
index 000000000000..dc06ae2cb5d3
--- /dev/null
+++ b/net/squall/pkg-descr
@@ -0,0 +1,8 @@
+pdtpd is a server for the Peer Distributed Transfer Protocol (PDTP),
+a BitTorrent-like protocol with stricter server control and support
+for exporting large, changing hierarchical filesystems (i.e. more akin
+to HTTP/FTP).
+
+For a more thorough description of PDTP, see http://www.pdtp.org/.
+
+WWW: http://pdtpd.sourceforge.net/
diff --git a/net/squall/pkg-plist b/net/squall/pkg-plist
new file mode 100644
index 000000000000..be03e7cc44ab
--- /dev/null
+++ b/net/squall/pkg-plist
@@ -0,0 +1,8 @@
+sbin/squall
+sbin/squallhub
+sbin/squallproxy
+sbin/squirt
+%%DOCSDIR%%/draft-arcieri-peer-distributed-transfer-protocol.txt
+%%DOCSDIR%%/transactions.txt
+%%DOCSDIR%%/transfer_specification.txt
+@dirrm %%DOCSDIR%%