aboutsummaryrefslogtreecommitdiffstats
path: root/net/sslh
diff options
context:
space:
mode:
authorjadawin <jadawin@FreeBSD.org>2012-02-13 16:50:09 +0800
committerjadawin <jadawin@FreeBSD.org>2012-02-13 16:50:09 +0800
commit0b9c397cf6d0d17930070460278155c000b068c9 (patch)
treeb4a64f8773fcd3a91f352ff89d75a706c50fa269 /net/sslh
parent0ad18270cc9766d271e976b3d06565e57926d6b4 (diff)
downloadfreebsd-ports-gnome-0b9c397cf6d0d17930070460278155c000b068c9.tar.gz
freebsd-ports-gnome-0b9c397cf6d0d17930070460278155c000b068c9.tar.zst
freebsd-ports-gnome-0b9c397cf6d0d17930070460278155c000b068c9.zip
- Update to 1.10
- Give maintainership to submitter PR: ports/163019 Submitted by: Olivier Cochard-Labbe <olivier@cochard.me> Approved by: maintainer
Diffstat (limited to 'net/sslh')
-rw-r--r--net/sslh/Makefile14
-rw-r--r--net/sslh/distinfo4
-rw-r--r--net/sslh/files/patch-Makefile12
-rw-r--r--net/sslh/files/sslh.in25
-rw-r--r--net/sslh/pkg-descr6
-rw-r--r--net/sslh/pkg-plist3
6 files changed, 41 insertions, 23 deletions
diff --git a/net/sslh/Makefile b/net/sslh/Makefile
index 10d3f0ccac0d..838d80199948 100644
--- a/net/sslh/Makefile
+++ b/net/sslh/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= sslh
-PORTVERSION= 1.7a
-PORTREVISION= 1
+PORTVERSION= 1.10
CATEGORIES= net
MASTER_SITES= http://www.rutschle.net/tech/
-MAINTAINER= jnlin@csie.nctu.edu.tw
+MAINTAINER= olivier@cochard.me
COMMENT= A ssl/ssh multiplexer
USE_GMAKE= yes
@@ -20,7 +19,9 @@ USE_PERL5_BUILD= yes
.if !defined(NO_INSTALL_MANPAGES)
MAN8= sslh.8
.endif
-PLIST_FILES= sbin/sslh
+
+VARDIR= /var
+PLIST_SUB= VARDIR=${VARDIR}
USE_RC_SUBR= sslh
@@ -28,7 +29,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|^PREFIX=/usr/local|PREFIX=${PREFIX}|g' ${WRKSRC}/Makefile
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/sslh ${PREFIX}/sbin
+ @${INSTALL_PROGRAM} ${WRKSRC}/sslh-fork ${PREFIX}/sbin
+ @${INSTALL_PROGRAM} ${WRKSRC}/sslh-select ${PREFIX}/sbin
+ @${MKDIR} ${VARDIR}/run/${PORTNAME}
+ @${CHOWN} -R nobody:nobody ${VARDIR}/run/${PORTNAME}
.if !defined(NO_INSTALL_MANPAGES)
@${INSTALL_MAN} ${WRKSRC}/sslh.8 ${MANPREFIX}/man/man8
.endif
diff --git a/net/sslh/distinfo b/net/sslh/distinfo
index 33490d79d209..ffb0fe7ed52a 100644
--- a/net/sslh/distinfo
+++ b/net/sslh/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sslh-1.7a.tar.gz) = add698342ea622e5085a26f05e4ec613763f71ff203202cadfa119a45659e13a
-SIZE (sslh-1.7a.tar.gz) = 9733
+SHA256 (sslh-1.10.tar.gz) = 5554e42969a00955048b45d3d269785bbd0211d4fb2b4cf5e79503b592695771
+SIZE (sslh-1.10.tar.gz) = 25293
diff --git a/net/sslh/files/patch-Makefile b/net/sslh/files/patch-Makefile
index d3d38cde3a50..8f2ecf3d096d 100644
--- a/net/sslh/files/patch-Makefile
+++ b/net/sslh/files/patch-Makefile
@@ -1,7 +1,7 @@
---- Makefile 2010-02-01 19:18:23.000000000 +0800
-+++ Makefile.new 2010-03-29 00:43:42.198577686 +0800
-@@ -4,7 +4,7 @@
- USELIBWRAP=1 # Use libwrap?
+--- Makefile.old 2011-12-02 10:16:46.000000000 +0000
++++ Makefile 2011-12-02 10:18:04.000000000 +0000
+@@ -5,7 +5,7 @@
+ COV_TEST= # Perform test coverage?
PREFIX=/usr/local
-MAN=sslh.8.gz # man page name
@@ -9,8 +9,8 @@
# End of configuration -- the rest should take care of
# itself
-@@ -27,7 +27,7 @@
- strip sslh
+@@ -46,7 +46,7 @@
+ $(CC) $(CFLAGS) -o echosrv echosrv.o common.o $(LIBS)
$(MAN): sslh.pod Makefile
- pod2man --section=8 --release=$(VERSION) --center=" " sslh.pod | gzip -9 - > $(MAN)
diff --git a/net/sslh/files/sslh.in b/net/sslh/files/sslh.in
index e56973fe9351..f21854198bfa 100644
--- a/net/sslh/files/sslh.in
+++ b/net/sslh/files/sslh.in
@@ -14,6 +14,9 @@
# sslh_enable="YES"
#
# You can fine tune others variables too:
+# sslh_mode="fork | select"
+# fork: stable but slow performance
+# select: new but high performance
# sslh_fib="NONE"
# sslh_pidfile="/var/run/sslh.pid"
# sslh_ssltarget="localhost:443"
@@ -40,24 +43,32 @@ sslh_setfib() {
name="sslh"
rcvar=sslh_enable
-command="%%PREFIX%%/sbin/${name}"
start_precmd="sslh_setfib"
+stop_postcmd="sslh_postcmd"
load_rc_config $name
sslh_enable=${sslh_enable:-"NO"}
+sslh_mode=${sslh_mode:-"fork"}
sslh_fib=${sslh_fib:-"NONE"}
sslh_listening=${sslh_listening:-"0.0.0.0:443"}
sslh_sshtarget=${sslh_sshtarget:-"localhost:22"}
sslh_ssltarget=${sslh_ssltarget:-"localhost:8443"}
-sslh_uid=${sslh_uid:-"nobody"}
sslh_sshtimeout=${sslh_sshtimeout:-"2"}
-sslh_ssltarget=${sslh_ssltarget:-"localhost:8443"}
-
-pidfile=${sslh_pidfile:-"/var/run/sslh.pid"}
+sslh_openvpntarget=${sslh_openvpntarget:-"localhost:1193"}
+sslh_xmpptarget=${sslh_xmpptarget:-"localhost:5222"}
+sslh_tinctarget=${sslh_tinctarget:-"localhost:655"}
+pidfile=${sslh_pidfile:-"/var/run/sslh/sslh.pid"}
+command="%%PREFIX%%/sbin/${name}-${sslh_mode}"
command_args="-t ${sslh_sshtimeout} -p ${sslh_listening} \
- -l ${sslh_ssltarget} -s ${sslh_sshtarget} -P ${pidfile} \
- -u ${sslh_uid}"
+ --ssl ${sslh_ssltarget} --ssh ${sslh_sshtarget} -P ${pidfile} \
+ --user nobody --openvpn ${sslh_openvpntarget} \
+ --xmpp ${sslh_xmpptarget} --tinc ${sslh_tinctarget}"
+
+sslh_postcmd()
+{
+ rm -f ${pidfile}
+}
run_rc_command "$1"
diff --git a/net/sslh/pkg-descr b/net/sslh/pkg-descr
index 1027458a28c1..a908ab62d07c 100644
--- a/net/sslh/pkg-descr
+++ b/net/sslh/pkg-descr
@@ -1,5 +1,5 @@
-sslh lets one accept both HTTPS and SSH connections on the same port. It makes
-it possible to connect to an SSH server on port 443 (e.g. from inside a
-corporate firewall) while still serving HTTPS on that port.
+sslh accepts HTTPS, SSH, OpenVPN, tinc and XMPP connections on the same port.
+This makes it possible to connect to any of these servers on port 443 while
+ still serving HTTPS on that port.
WWW: http://www.rutschle.net/tech/sslh.shtml
diff --git a/net/sslh/pkg-plist b/net/sslh/pkg-plist
new file mode 100644
index 000000000000..fddf592903e5
--- /dev/null
+++ b/net/sslh/pkg-plist
@@ -0,0 +1,3 @@
+sbin/sslh-fork
+sbin/sslh-select
+@dirrmtry %%VARDIR%%/run/sslh