aboutsummaryrefslogtreecommitdiffstats
path: root/net/tramp/files
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2008-07-03 06:22:47 +0800
committerkuriyama <kuriyama@FreeBSD.org>2008-07-03 06:22:47 +0800
commit814dd5a4defb61afa61e9188368ccd2342a25e28 (patch)
treed9353532dee1617b453cbd26558ab7e96053e927 /net/tramp/files
parenta9883552003d527e80ee20b040e106ee96455a85 (diff)
downloadfreebsd-ports-gnome-814dd5a4defb61afa61e9188368ccd2342a25e28.tar.gz
freebsd-ports-gnome-814dd5a4defb61afa61e9188368ccd2342a25e28.tar.zst
freebsd-ports-gnome-814dd5a4defb61afa61e9188368ccd2342a25e28.zip
- Upgrade to 2.1.12.
- Don't use EMACS_PORT_NAME?=emacs21 Submitted by: "Douglas K. Rand" <rand@meridian-enviro.com> PR: ports/121604 (part of)
Diffstat (limited to 'net/tramp/files')
-rw-r--r--net/tramp/files/patch-configure.ac13
-rw-r--r--net/tramp/files/patch-texi-Makefile.in16
-rw-r--r--net/tramp/files/patch-tramp.el22
3 files changed, 14 insertions, 37 deletions
diff --git a/net/tramp/files/patch-configure.ac b/net/tramp/files/patch-configure.ac
index 7ce9acd3a8e8..89b64f73d4d3 100644
--- a/net/tramp/files/patch-configure.ac
+++ b/net/tramp/files/patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.ac.orig Sun Jan 16 19:43:17 2005
-+++ configure.ac Tue Feb 22 09:45:18 2005
-@@ -58,12 +58,11 @@
+--- configure.ac.orig 2007-12-23 05:39:52.000000000 -0600
++++ configure.ac 2008-03-11 10:07:43.000000000 -0500
+@@ -55,11 +55,10 @@
AC_EMACS_INFO
# Handle contrib files. "-" must be encoded as "_".
@@ -9,8 +9,7 @@
AC_CONTRIB_FILES([base64_encode_region], [base64.el])
AC_CONTRIB_FILES([format_spec], [format_spec.el])
- AC_CONTRIB_FILES([md5], [md5.el], [optional])
-AC_CONTRIB_FILES([password_cache_add], [password.el], [optional])
- AC_CONTRIB_FILES([uudecode_decode_region], [uudecode.el])
- dnl run-at-time for XEmacs can be find in fsf-compat. Unfortunately,
- dnl password.el doesn't honor it, and it requires run-at-time mandatory.
+ if test "${EMACS_GW}" = yes; then
+ AC_CONTRIB_FILES([socks_open_network_stream], [socks.el], [optional])
+ fi
diff --git a/net/tramp/files/patch-texi-Makefile.in b/net/tramp/files/patch-texi-Makefile.in
index 212478dbb1b0..13b232a9235e 100644
--- a/net/tramp/files/patch-texi-Makefile.in
+++ b/net/tramp/files/patch-texi-Makefile.in
@@ -1,7 +1,7 @@
---- texi/Makefile.in.orig Wed Mar 15 06:27:20 2006
-+++ texi/Makefile.in Tue Sep 5 08:44:47 2006
-@@ -50,10 +50,10 @@
- TEXI_FILES = tramp.texi trampver.texi \
+--- texi/Makefile.in.orig 2007-09-28 09:32:11.000000000 -0500
++++ texi/Makefile.in 2008-03-11 10:11:25.000000000 -0500
+@@ -51,10 +51,10 @@
+ TEXI_FILES = tramp.texi trampver.texi doclicense.texi \
$(if $(findstring yes, @INSTALL_CHAPTER@), trampinst.texi)
JA_TEXI_FILES = $(if $(findstring yes, @JA_MANUAL@), tramp_ja.texi)
-INFO_FILES = $(localinfodir)/tramp \
@@ -15,7 +15,7 @@
CLEAN_FILES = @TRAMP_CLEAN_FILES@ $(wildcard $(localinfodir)/*)
# To be used by maintainer only
-@@ -66,19 +66,19 @@
+@@ -67,19 +67,19 @@
tramp: $(INFO_FILES) $(localinfodir)/dir
@@ -30,9 +30,9 @@
-$(localinfodir)/tramp $(localinfodir)/tramp_ja: $(TEXI_FILES) $(JA_TEXI_FILES)
+$(localinfodir)/%.info: $(TEXI_FILES) $(JA_TEXI_FILES)
$(MKDIR) $(dir $@)
- $(MAKEINFO) --footnote-style=end -D $(EMACS_INFO) -D $(JA_MANUAL) \
-- -D $(INSTALL_CHAPTER) -o $@ $(notdir $@).texi
-+ -D $(INSTALL_CHAPTER) -o $@ $*.texi
+ $(MAKEINFO) --footnote-style=end -D $(EMACS_GW) -D $(EMACS_INFO) \
+- -D $(JA_MANUAL) -D $(INSTALL_CHAPTER) -o $@ $(notdir $@).texi
++ -D $(JA_MANUAL) -D $(INSTALL_CHAPTER) -o $@ $*.texi
-$(DESTDIR)$(infodir)/tramp $(DESTDIR)$(infodir)/tramp_ja:
+$(DESTDIR)$(infodir)/tramp.info $(DESTDIR)$(infodir)/tramp_ja.info:
diff --git a/net/tramp/files/patch-tramp.el b/net/tramp/files/patch-tramp.el
index 48e7d1b9cd8b..e69de29bb2d1 100644
--- a/net/tramp/files/patch-tramp.el
+++ b/net/tramp/files/patch-tramp.el
@@ -1,22 +0,0 @@
---- lisp/tramp.el.orig Sat Sep 23 19:12:34 2006
-+++ lisp/tramp.el Sat Sep 23 19:13:19 2006
-@@ -5922,8 +5922,8 @@
- "Return the right method string to use.
- This is METHOD, if non-nil. Otherwise, do a lookup in
- `tramp-default-method-alist'."
-- (if (tramp-completion-mode)
-- method
-+; (if (tramp-completion-mode)
-+; method
- (or method
- (let ((choices tramp-default-method-alist)
- lmethod item)
-@@ -5934,7 +5934,7 @@
- (setq lmethod (nth 2 item))
- (setq choices nil)))
- lmethod)
-- tramp-default-method)))
-+ tramp-default-method));)
-
- (defsubst tramp-find-user (method user host)
- "Return the right user string to use.