aboutsummaryrefslogtreecommitdiffstats
path: root/net/tramp
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2004-06-14 18:03:26 +0800
committerkuriyama <kuriyama@FreeBSD.org>2004-06-14 18:03:26 +0800
commit2c19f9b0b9f9c5a1e56d5c0e0789df615832a869 (patch)
tree70c282eb3f53e3ff02e1e7d4fba700a2a5993f46 /net/tramp
parent2aafeb1dc12c02a64d376cf72bd2b4c9d7b1c185 (diff)
downloadfreebsd-ports-gnome-2c19f9b0b9f9c5a1e56d5c0e0789df615832a869.tar.gz
freebsd-ports-gnome-2c19f9b0b9f9c5a1e56d5c0e0789df615832a869.tar.zst
freebsd-ports-gnome-2c19f9b0b9f9c5a1e56d5c0e0789df615832a869.zip
Fix elisp error at connecting to remote site.
Obtained from: tramp CVS
Diffstat (limited to 'net/tramp')
-rw-r--r--net/tramp/Makefile1
-rw-r--r--net/tramp/files/patch-tramp.el42
2 files changed, 43 insertions, 0 deletions
diff --git a/net/tramp/Makefile b/net/tramp/Makefile
index f1f4d19721c5..ee9ad76c1151 100644
--- a/net/tramp/Makefile
+++ b/net/tramp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tramp
PORTVERSION= 2.0.41
+PORTREVISION= 1
CATEGORIES= net elisp
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net/tramp/files/patch-tramp.el b/net/tramp/files/patch-tramp.el
new file mode 100644
index 000000000000..aad7656df633
--- /dev/null
+++ b/net/tramp/files/patch-tramp.el
@@ -0,0 +1,42 @@
+Index: lisp/tramp.el
+===================================================================
+RCS file: /cvsroot/tramp/tramp/lisp/tramp.el,v
+retrieving revision 2.359.2.3
+retrieving revision 2.359.2.4
+diff -u -r2.359.2.3 -r2.359.2.4
+--- lisp/tramp.el 29 May 2004 21:40:49 -0000 2.359.2.3
++++ lisp/tramp.el 30 May 2004 20:55:59 -0000 2.359.2.4
+@@ -1885,6 +1885,16 @@
+ ;; To be activated for debugging containing this macro
+ (def-edebug-spec with-parsed-tramp-file-name t)
+
++(defmacro tramp-let-maybe (variable value &rest body)
++ "Let-bind VARIABLE to VALUE in BODY, but only if VARIABLE is not obsolete.
++BODY is executed whether or not the variable is obsolete.
++The intent is to protect against `obsolete variable' warnings."
++ `(if (get ',variable 'byte-obsolete-variable)
++ (progn ,@body)
++ (let ((,variable ,value))
++ ,@body)))
++(put 'tramp-let-maybe 'lisp-indent-function 2)
++
+ ;;; Config Manipulation Functions:
+
+ (defun tramp-set-completion-function (method function-list)
+@@ -6790,16 +6800,6 @@
+ (funcall (symbol-function 'process-kill-without-query)
+ process flag)))
+
+-(defmacro tramp-let-maybe (variable value &rest body)
+- "Let-bind VARIABLE to VALUE in BODY, but only if VARIABLE is not obsolete.
+-BODY is executed whether or not the variable is obsolete.
+-The intent is to protect against `obsolete variable' warnings."
+- `(if (get 'byte-obsolete-variable ',variable)
+- (progn ,@body)
+- (let ((,variable ,value))
+- ,@body)))
+-(put 'tramp-let-maybe 'lisp-indent-function 2)
+-
+
+ ;; ------------------------------------------------------------
+ ;; -- Kludges section --