aboutsummaryrefslogtreecommitdiffstats
path: root/net/unfs3
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-01-21 01:32:06 +0800
committerwxs <wxs@FreeBSD.org>2009-01-21 01:32:06 +0800
commit16cc339c41cf115578885e532d8f4694eac43e40 (patch)
treeae7f1e4aae948440144a6787133c5427521645aa /net/unfs3
parentc0fe8e04fd31cf1a9791cdf5978c01ebbabcfb62 (diff)
downloadfreebsd-ports-gnome-16cc339c41cf115578885e532d8f4694eac43e40.tar.gz
freebsd-ports-gnome-16cc339c41cf115578885e532d8f4694eac43e40.tar.zst
freebsd-ports-gnome-16cc339c41cf115578885e532d8f4694eac43e40.zip
- Update to 0.9.22
- Switch to SF macro - Remove unnecessary patches and post-patch
Diffstat (limited to 'net/unfs3')
-rw-r--r--net/unfs3/Makefile9
-rw-r--r--net/unfs3/distinfo6
-rw-r--r--net/unfs3/files/patch-configure.ac8
-rw-r--r--net/unfs3/files/patch-daemon.c11
4 files changed, 5 insertions, 29 deletions
diff --git a/net/unfs3/Makefile b/net/unfs3/Makefile
index 93bbec0b7959..6fa5b9282bed 100644
--- a/net/unfs3/Makefile
+++ b/net/unfs3/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= unfs3
-PORTVERSION= 0.9.21
-PORTREVISION= 1
+PORTVERSION= 0.9.22
CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= wxs@FreeBSD.org
COMMENT= A user-space implementation of the NFSv3 server specification
@@ -26,7 +24,4 @@ PLIST_FILES= sbin/unfsd
CONFIGURE_ARGS+= --enable-cluster
.endif
-post-patch:
- @${REINPLACE_CMD} 's/no_all_sqash/no_all_squash/' ${WRKSRC}/Config/exports.y
-
.include <bsd.port.mk>
diff --git a/net/unfs3/distinfo b/net/unfs3/distinfo
index 3139c97bdad0..8fc4f505db2b 100644
--- a/net/unfs3/distinfo
+++ b/net/unfs3/distinfo
@@ -1,3 +1,3 @@
-MD5 (unfs3-0.9.21.tar.gz) = fbd1c82bf8048c1d5289158fe11a9ab4
-SHA256 (unfs3-0.9.21.tar.gz) = da7b8fae1f7e97024432878ebeb555035ea59feaaaa1d50fe714e351ba2a04bf
-SIZE (unfs3-0.9.21.tar.gz) = 168528
+MD5 (unfs3-0.9.22.tar.gz) = ddf679a5d4d80096a59f3affc64f16e5
+SHA256 (unfs3-0.9.22.tar.gz) = 482222cae541172c155cd5dc9c2199763a6454b0c5c0619102d8143bb19fdf1c
+SIZE (unfs3-0.9.22.tar.gz) = 168447
diff --git a/net/unfs3/files/patch-configure.ac b/net/unfs3/files/patch-configure.ac
index 7333b289d0b8..79f00d6a8146 100644
--- a/net/unfs3/files/patch-configure.ac
+++ b/net/unfs3/files/patch-configure.ac
@@ -1,13 +1,5 @@
--- ./configure.ac.orig 2008-02-16 14:45:54.000000000 -0500
+++ ./configure.ac 2008-08-31 19:54:55.000000000 -0400
-@@ -14,7 +14,6 @@
- AC_CHECK_HEADERS(sys/mnttab.h,,,[#include <stdio.h>])
- AC_CHECK_HEADERS(sys/mount.h,,,[#include <stdio.h>])
- AC_CHECK_HEADERS(sys/vmount.h,,,[#include <stdio.h>])
--AC_CHECK_HEADERS(rpc/svc_soc.h,,,[#include <rpc/types.h> #include <rpc/rpc.h>])
- AC_CHECK_HEADERS(linux/ext2_fs.h,,,[#include <unistd.h>])
- AC_CHECK_TYPES(int32,,,[#include <stdio.h> #include <sys/inttypes.h>])
- AC_CHECK_TYPES(uint32,,,[#include <stdio.h> #include <sys/inttypes.h>])
@@ -29,7 +28,6 @@
AC_CHECK_FUNCS(vsyslog)
AC_CHECK_FUNCS(lchown)
diff --git a/net/unfs3/files/patch-daemon.c b/net/unfs3/files/patch-daemon.c
deleted file mode 100644
index 814fa0edce0a..000000000000
--- a/net/unfs3/files/patch-daemon.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./daemon.c.orig 2008-08-31 22:26:12.000000000 -0400
-+++ ./daemon.c 2008-08-31 22:26:25.000000000 -0400
-@@ -131,7 +131,7 @@
-
- l = sizeof(v);
-
-- if (getsockopt(rqstp->rq_xprt->xp_sock, SOL_SOCKET, SO_TYPE, &v, &l) < 0) {
-+ if (getsockopt(rqstp->rq_xprt->xp_fd, SOL_SOCKET, SO_TYPE, &v, &l) < 0) {
- logmsg(LOG_CRIT, "unable to determine socket type");
- return -1;
- }