aboutsummaryrefslogtreecommitdiffstats
path: root/net/unix2tcp/Makefile
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-25 16:37:21 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-25 16:37:21 +0800
commit09030e6960d58f48d7a451b96055c25905a68e9f (patch)
treeeee0315bbdd391ff7ac2f07f328637e712608167 /net/unix2tcp/Makefile
parent73b81f94b4977b64f30be0b8e56c16517a87d525 (diff)
downloadfreebsd-ports-gnome-09030e6960d58f48d7a451b96055c25905a68e9f.tar.gz
freebsd-ports-gnome-09030e6960d58f48d7a451b96055c25905a68e9f.tar.zst
freebsd-ports-gnome-09030e6960d58f48d7a451b96055c25905a68e9f.zip
Support staging
Diffstat (limited to 'net/unix2tcp/Makefile')
-rw-r--r--net/unix2tcp/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/net/unix2tcp/Makefile b/net/unix2tcp/Makefile
index 2e1202541d38..6d36a8fa1386 100644
--- a/net/unix2tcp/Makefile
+++ b/net/unix2tcp/Makefile
@@ -13,7 +13,8 @@ COMMENT= A connection forwarder that converts Unix sockets into TCP sockets
CFLAGS+= -DHAVE_CONFIG_H -I.
GNU_CONFIGURE= yes
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-build:
cd ${WRKSRC} && \
${CC} ${CFLAGS} -c ${PORTNAME}.c -o ${PORTNAME}.o &&\
@@ -24,11 +25,8 @@ do-build:
${CC} ${CFLAGS} -c utelnet.c -o utelnet.o
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
-
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/README
.include <bsd.port.mk>