aboutsummaryrefslogtreecommitdiffstats
path: root/net/vino
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2007-03-21 14:20:04 +0800
committermarcus <marcus@FreeBSD.org>2007-03-21 14:20:04 +0800
commit961e8ef704efc42b0dde9db2301ccad02652a4c5 (patch)
tree1cc15312dc9ce707c3f361db07c6f8872c3422d8 /net/vino
parent4ce9bc427a49b05af7802637d242d421bd6ad201 (diff)
downloadfreebsd-ports-gnome-961e8ef704efc42b0dde9db2301ccad02652a4c5.tar.gz
freebsd-ports-gnome-961e8ef704efc42b0dde9db2301ccad02652a4c5.tar.zst
freebsd-ports-gnome-961e8ef704efc42b0dde9db2301ccad02652a4c5.zip
Make IPv6 support optional (defaulting to off). The reason for off by default
is that if vino can establish an IPv6 socket, then it will not create an IPv4 socket. None of the FreeBSD VNC clients seem to support IPv6 (prove me wrong) so defaulting v6 to off is probably a good thing.
Diffstat (limited to 'net/vino')
-rw-r--r--net/vino/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/net/vino/Makefile b/net/vino/Makefile
index c56835ec6b58..909de0871ad1 100644
--- a/net/vino/Makefile
+++ b/net/vino/Makefile
@@ -8,6 +8,7 @@
PORTNAME= vino
PORTVERSION= 2.18.0
+PORTREVISION= 1
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -31,4 +32,14 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
GCONF_SCHEMAS= vino-server.schemas
-.include <bsd.port.mk>
+OPTIONS= IPV6 "Enable IPv6 support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
+.else
+CONFIGURE_ARGS+= --disable-ipv6
+.endif
+
+.include <bsd.port.post.mk>