aboutsummaryrefslogtreecommitdiffstats
path: root/net/vomit/Makefile
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2001-08-23 19:33:55 +0800
committerkris <kris@FreeBSD.org>2001-08-23 19:33:55 +0800
commitd577a94527824e16a4aef583af868cb589b4af79 (patch)
treedd89835ed70234a626fe543cd69336677c3eef2c /net/vomit/Makefile
parentaa7fbfc4007ea963c07a80ab417d61222dfcaff7 (diff)
downloadfreebsd-ports-gnome-d577a94527824e16a4aef583af868cb589b4af79.tar.gz
freebsd-ports-gnome-d577a94527824e16a4aef583af868cb589b4af79.tar.zst
freebsd-ports-gnome-d577a94527824e16a4aef583af868cb589b4af79.zip
Add vomit 0.1
The vomit utility converts a Cisco IP phone conversation into a wave file that can be played with ordinary sound players. The phone conversation can either be played directly from the network or from a tcpdump output file. Vomit is also capable of inserting wavefiles into ongoing telephone conversations. Vomit can be used as a network debugging tool, a speaker phone, etc ... --- I haven't tested whether this works. Obtained from: OpenBSD
Diffstat (limited to 'net/vomit/Makefile')
-rw-r--r--net/vomit/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/net/vomit/Makefile b/net/vomit/Makefile
new file mode 100644
index 000000000000..ef1e23228df7
--- /dev/null
+++ b/net/vomit/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: vomit
+# Date created: 23 Aug 2001
+# Whom: Kris Kennaway <kris@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vomit
+PORTVERSION= 0.1
+CATEGORIES= net security
+MASTER_SITES= http://www.monkey.org/~provos/
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent \
+ ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+
+GNU_CONFIGURE= yes
+
+WRKSRC= ${WRKDIR}/vomit
+
+MAN1= vomit.1
+
+.include <bsd.port.mk>