aboutsummaryrefslogtreecommitdiffstats
path: root/net/vortex
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2013-12-29 13:21:45 +0800
committerwxs <wxs@FreeBSD.org>2013-12-29 13:21:45 +0800
commit7e9411b8390d9dd1d536b31fa907ee5f031701dc (patch)
tree90c41b3abc04438a49c09337a6fd5450dd943b08 /net/vortex
parentc2e323ed8992875845771c34bd397f87438bd30c (diff)
downloadfreebsd-ports-gnome-7e9411b8390d9dd1d536b31fa907ee5f031701dc.tar.gz
freebsd-ports-gnome-7e9411b8390d9dd1d536b31fa907ee5f031701dc.tar.zst
freebsd-ports-gnome-7e9411b8390d9dd1d536b31fa907ee5f031701dc.zip
Fix build on current.
Diffstat (limited to 'net/vortex')
-rw-r--r--net/vortex/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/net/vortex/Makefile b/net/vortex/Makefile
index 6b2732e3e89b..2fa1c382ed95 100644
--- a/net/vortex/Makefile
+++ b/net/vortex/Makefile
@@ -20,9 +20,10 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-2.9.0
USE_GNOME= glib20
NO_STAGE= yes
+
do-build:
cd ${WRKSRC} && ${CC} -c vortex.c -I${LOCALBASE}/include
- cd ${WRKSRC} && ${CC} -o vortex vortex.o -L${LOCALBASE}/lib ${LOCALBASE}/lib/libnids.a `${LIBNET_CONFIG} --libs` -lgthread-2.0 -lpcap
+ cd ${WRKSRC} && ${CC} -v -o vortex vortex.o -L${LOCALBASE}/lib ${LOCALBASE}/lib/libnids.a `${LIBNET_CONFIG} --libs` -lglib-2.0 -lgthread-2.0 -lpcap
cd ${WRKSRC} && ${CC} -o xpipes xpipes.c ${PTHREAD_LIBS}
do-install: