aboutsummaryrefslogtreecommitdiffstats
path: root/net/vtun/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-07-02 16:31:21 +0800
committerwill <will@FreeBSD.org>2000-07-02 16:31:21 +0800
commita38b1e089200ba0ca8316600208c87d39b6ea07c (patch)
tree79cb7e1fe57516d96269af4a96cdda21fa41807f /net/vtun/Makefile
parent2a3b6b8ae6c81e7b10af62ad0f7182bcaeb58c2f (diff)
downloadfreebsd-ports-gnome-a38b1e089200ba0ca8316600208c87d39b6ea07c.tar.gz
freebsd-ports-gnome-a38b1e089200ba0ca8316600208c87d39b6ea07c.tar.zst
freebsd-ports-gnome-a38b1e089200ba0ca8316600208c87d39b6ea07c.zip
Add vtun, which is "the easiest way to create Virtual Tunnels over TCP/IP
networks with traffic shaping, compression and encryption." PR: 16629 Submitted by: kevlo
Diffstat (limited to 'net/vtun/Makefile')
-rw-r--r--net/vtun/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/net/vtun/Makefile b/net/vtun/Makefile
new file mode 100644
index 000000000000..305cafab061d
--- /dev/null
+++ b/net/vtun/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: vtun
+# Date created: 05 Feb 2000
+# Whom: Kevin Lo <kevlo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vtun
+PORTVERSION= 2.3
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= vtun
+
+MAINTAINER= kevlo@FreeBSD.org
+
+LIB_DEPENDS= lzo.1:${PORTSDIR}/archivers/lzo
+
+MAN5= vtund.conf.5
+MAN8= vtund.8
+MANCOMPRESSED= no
+
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--localstatedir=/var \
+ --with-crypto-headers=${LOCALBASE}/include/openssl \
+ --with-crypto-lib=${LOCALBASE}/lib \
+ --with-lzo-headers=${LOCALBASE}/include \
+ --with-lzo-lib=${LOCALBASE}/lib
+
+ALL_TARGET= vtund
+
+.include <bsd.port.mk>