aboutsummaryrefslogtreecommitdiffstats
path: root/net/wireshark
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-07-22 08:24:08 +0800
committermarcus <marcus@FreeBSD.org>2004-07-22 08:24:08 +0800
commit0bf6520101a0301069c72915cf00e7b4222212cd (patch)
treea77e5fbcad456460de574f4c89e2ec9e66353b7a /net/wireshark
parente795bbca4ef71f7755da5f33242328f0cfde99be (diff)
downloadfreebsd-ports-gnome-0bf6520101a0301069c72915cf00e7b4222212cd.tar.gz
freebsd-ports-gnome-0bf6520101a0301069c72915cf00e7b4222212cd.tar.zst
freebsd-ports-gnome-0bf6520101a0301069c72915cf00e7b4222212cd.zip
Add a forgotten patch to really fix the capture lockups when ethereal is
built with GTK+ 2 support.
Diffstat (limited to 'net/wireshark')
-rw-r--r--net/wireshark/Makefile1
-rw-r--r--net/wireshark/files/patch-capture.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 9768dc1d9fe3..ca4659130709 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ethereal
PORTVERSION= 0.10.5
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.ethereal.com/pub/ethereal/all-versions/ \
ftp://gd.tuwien.ac.at/infosys/security/ethereal/all-versions/ \
diff --git a/net/wireshark/files/patch-capture.c b/net/wireshark/files/patch-capture.c
new file mode 100644
index 000000000000..a31c93ba51bc
--- /dev/null
+++ b/net/wireshark/files/patch-capture.c
@@ -0,0 +1,11 @@
+--- capture.c.orig Thu Jul 22 00:23:01 2004
++++ capture.c Thu Jul 22 00:23:15 2004
+@@ -126,7 +126,7 @@
+ * XXX - the various BSDs appear to define BSD in <sys/param.h>; we don't
+ * want to include it if it's not present on this platform, however.
+ */
+-#if !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__OpenBSD__) && \
++#if !defined(__NetBSD__) && !defined(__OpenBSD__) && \
+ !defined(__bsdi__) && !defined(__APPLE__) && !defined(_WIN32) && \
+ !defined(__CYGWIN__)
+ # define MUST_DO_SELECT