aboutsummaryrefslogtreecommitdiffstats
path: root/net/wmnet2
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-02-19 02:01:59 +0800
committerpat <pat@FreeBSD.org>2002-02-19 02:01:59 +0800
commitecc7edf0f98851235622f6fd9be25d6122799fec (patch)
tree55897b502cb77e4b43ae6b86bb7c7376a3adde20 /net/wmnet2
parent194825283070db00226c26c012d5b113df73bb99 (diff)
downloadfreebsd-ports-gnome-ecc7edf0f98851235622f6fd9be25d6122799fec.tar.gz
freebsd-ports-gnome-ecc7edf0f98851235622f6fd9be25d6122799fec.tar.zst
freebsd-ports-gnome-ecc7edf0f98851235622f6fd9be25d6122799fec.zip
Fix a problem where the transmit and receive arrows do not flash.
PR: 35030 Submitted by: Richard Glidden <richard@glidden.org> Approved by: maintainer
Diffstat (limited to 'net/wmnet2')
-rw-r--r--net/wmnet2/Makefile2
-rw-r--r--net/wmnet2/files/patch-aa76
2 files changed, 37 insertions, 41 deletions
diff --git a/net/wmnet2/Makefile b/net/wmnet2/Makefile
index cfe28b7df718..fc0964e638b7 100644
--- a/net/wmnet2/Makefile
+++ b/net/wmnet2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wmnet2
PORTVERSION= 1.06
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.digitalkaos.net/linux/wmnet/download/
DISTNAME= wmnet-${PORTVERSION}
diff --git a/net/wmnet2/files/patch-aa b/net/wmnet2/files/patch-aa
index c09100b8bfa9..ac87895a0dc2 100644
--- a/net/wmnet2/files/patch-aa
+++ b/net/wmnet2/files/patch-aa
@@ -1,41 +1,37 @@
-*** drivers.c.orig Fri Sep 7 16:39:23 2001
---- drivers.c Fri Jun 29 23:21:52 2001
-***************
-*** 15,20 ****
---- 15,21 ----
- #include<X11/Xlib.h>
- #include<fcntl.h>
- #include<sys/types.h>
-+ #include <sys/time.h>
- #include<sys/stat.h>
- #include<sys/socket.h>
- #include<unistd.h>
-***************
-*** 24,29 ****
---- 25,32 ----
- /* For FreeBSD */
- #ifdef USE_KVM
- #include<net/if.h>
-+ #include <net/if_var.h>
-+ #include <net/if_types.h>
- #include<kvm.h>
- #include<nlist.h>
-
-***************
-*** 490,496 ****
- #ifdef __OpenBSD__
- ifnet_addr = (unsigned long)ifnet->if_list.tqe_next;
- #else
-! ifnet_addr = (unsigned long)ifnet->if_next;
- #endif
- }
- }
---- 493,500 ----
- #ifdef __OpenBSD__
- ifnet_addr = (unsigned long)ifnet->if_list.tqe_next;
- #else
-! //ifnet_addr = (unsigned long)ifnet->if_next;
-! ifnet_addr = (unsigned long) TAILQ_NEXT(ifnet,if_link);
- #endif
- }
+--- drivers.c.orig Thu May 4 20:34:29 2000
++++ drivers.c Mon Feb 18 12:54:45 2002
+@@ -15,6 +15,7 @@
+ #include<X11/Xlib.h>
+ #include<fcntl.h>
+ #include<sys/types.h>
++#include <sys/time.h>
+ #include<sys/stat.h>
+ #include<sys/socket.h>
+ #include<unistd.h>
+@@ -24,6 +25,8 @@
+ /* For FreeBSD */
+ #ifdef USE_KVM
+ #include<net/if.h>
++#include <net/if_var.h>
++#include <net/if_types.h>
+ #include<kvm.h>
+ #include<nlist.h>
+
+@@ -455,6 +458,8 @@
+ unsigned long ifnet_addr = ifnet_savedaddr;
+ char devname[16];
+ int flag = 0;
++ rx = False;
++ tx = False;
+ while (ifnet_addr && flag != (ACCOUNT_IN_FOUND|ACCOUNT_OUT_FOUND)) {
+ kvm_read(kvmfd, ifnet_addr, buffer, sizeof(struct ifnet));
+ #ifdef __OpenBSD__
+@@ -490,7 +495,7 @@
+ #ifdef __OpenBSD__
+ ifnet_addr = (unsigned long)ifnet->if_list.tqe_next;
+ #else
+- ifnet_addr = (unsigned long)ifnet->if_next;
++ ifnet_addr = (unsigned long) TAILQ_NEXT(ifnet,if_link);
+ #endif
}
+ }