aboutsummaryrefslogtreecommitdiffstats
path: root/net/wmwlmon/Makefile
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2008-05-10 17:00:09 +0800
committeritetcu <itetcu@FreeBSD.org>2008-05-10 17:00:09 +0800
commitabb59559178f81753e10f8dd6b92db13d3b41670 (patch)
tree3623498aaf8c0d014acae6bff50e7e49d4079717 /net/wmwlmon/Makefile
parentdf4b29d922e34d7c8eab1b6de3e0d706185984a6 (diff)
downloadfreebsd-ports-gnome-abb59559178f81753e10f8dd6b92db13d3b41670.tar.gz
freebsd-ports-gnome-abb59559178f81753e10f8dd6b92db13d3b41670.tar.zst
freebsd-ports-gnome-abb59559178f81753e10f8dd6b92db13d3b41670.zip
- fix build with gcc 4.2 [1]
- fix build on 7 after wi_req removal (remove support for wi(4)) [2] - unBROKEN [1] - unDEPRECIATE [1] - use REINPALCE_CMD PR: ports/123408 [1], [2] by itetcu@ (me) based on [1] Submitted by: Luke Dean <luked@pobox.com> [1]
Diffstat (limited to 'net/wmwlmon/Makefile')
-rw-r--r--net/wmwlmon/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/net/wmwlmon/Makefile b/net/wmwlmon/Makefile
index 13984f83d48a..2aeeba8a40ec 100644
--- a/net/wmwlmon/Makefile
+++ b/net/wmwlmon/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wmwlmon
PORTVERSION= 0.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net windowmaker
MASTER_SITES= http://www.nazgul.ch/dev/ \
http://dougbarton.us/Downloads/
@@ -25,18 +25,17 @@ PLIST_FILES= bin/wmwlmon
.if ${OSVERSION} < 600100
IGNORE= needs WLAN infrastructure from 6.0-RELEASE or newer
-.elif ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
+.elif ${OSVERSION} > 700047
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-wl.c ${PATCHDIR}/extra-patch-wmwlmon.1
+pre-everything::
+ @${ECHO_CMD} "========================================================"
+ @${ECHO_CMD} "On FreeBSD > 700047 there is no wi(4) support"
+ @${ECHO_CMD} "========================================================"
.endif
-DEPRECATED= Does not work after removal of wi_req
-EXPIRATION_DATE= 2008-07-03
-
post-patch:
- ${CP} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.presed
- ${SED} -e 's#/usr/X11R6#${LOCALBASE}#g' \
- -e 's#/usr/local#${LOCALBASE}#g' \
- ${WRKSRC}/Makefile.presed > ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's#/usr/X11R6#${LOCALBASE}#g' \
+ -e 's#/usr/local#${LOCALBASE}#g' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmwlmon ${PREFIX}/bin