aboutsummaryrefslogtreecommitdiffstats
path: root/net/wol
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-02-01 01:13:02 +0800
committerantoine <antoine@FreeBSD.org>2014-02-01 01:13:02 +0800
commit129cce2b0c130be386e9ac7d7e57d52f011f3cd5 (patch)
tree2c78b40b1ce4fe7881c54dbd069a318162fbc3eb /net/wol
parent4dcfe4ae4c386dbe24f668e734e51fffcfda99ae (diff)
downloadfreebsd-ports-gnome-129cce2b0c130be386e9ac7d7e57d52f011f3cd5.tar.gz
freebsd-ports-gnome-129cce2b0c130be386e9ac7d7e57d52f011f3cd5.tar.zst
freebsd-ports-gnome-129cce2b0c130be386e9ac7d7e57d52f011f3cd5.zip
- Stage support
- Use OPTIONS helpers
Diffstat (limited to 'net/wol')
-rw-r--r--net/wol/Makefile29
-rw-r--r--net/wol/pkg-plist1
2 files changed, 12 insertions, 18 deletions
diff --git a/net/wol/Makefile b/net/wol/Makefile
index 49ed814e9081..ac9d2845d1e2 100644
--- a/net/wol/Makefile
+++ b/net/wol/Makefile
@@ -11,29 +11,22 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Tool to wake up Wake-On-LAN compliant computers
USES= perl5
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
USE_PERL5= build
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
-MAN1= wol.1
INFO= wol
DOCS= AUTHORS NEWS README TODO
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext iconv
-PLIST_SUB= NLS=""
-.else
-CONFIGURE_ARGS= --disable-nls
-PLIST_SUB= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MDOCS}
+OPTIONS_DEFINE= DOCS NLS
+
+OPTIONS_SUB= yes
+NLS_USES= gettext iconv
+NLS_CONFIGURE_OFF= --disable-nls
+
post-install:
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/net/wol/pkg-plist b/net/wol/pkg-plist
index a5882d8950c9..c64fafd924c1 100644
--- a/net/wol/pkg-plist
+++ b/net/wol/pkg-plist
@@ -1,6 +1,7 @@
bin/wol
bin/wol-bootptab
bin/wol-dhcpdconf
+man/man1/wol.1.gz
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README