aboutsummaryrefslogtreecommitdiffstats
path: root/net/x2goclient/Makefile
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2019-03-10 01:11:32 +0800
committertcberner <tcberner@FreeBSD.org>2019-03-10 01:11:32 +0800
commit1a1d9b15d71590ff2294a53c224f826ae558420b (patch)
treec16260d6e246e38e4a41a0c5621d1e80a3151e46 /net/x2goclient/Makefile
parent8dc1b48ed6df044f0ddd95478c54701ba38616c4 (diff)
downloadfreebsd-ports-gnome-1a1d9b15d71590ff2294a53c224f826ae558420b.tar.gz
freebsd-ports-gnome-1a1d9b15d71590ff2294a53c224f826ae558420b.tar.zst
freebsd-ports-gnome-1a1d9b15d71590ff2294a53c224f826ae558420b.zip
net/x2goclient: switch to using Qt5
Diffstat (limited to 'net/x2goclient/Makefile')
-rw-r--r--net/x2goclient/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/net/x2goclient/Makefile b/net/x2goclient/Makefile
index 96492ca6b831..a96f8225334b 100644
--- a/net/x2goclient/Makefile
+++ b/net/x2goclient/Makefile
@@ -3,6 +3,7 @@
PORTNAME= x2goclient
PORTVERSION= 4.1.0.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://code.x2go.org/releases/source/x2goclient/
@@ -12,11 +13,6 @@ COMMENT= Qt client for the X2Go system
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= fails to build
-
-DEPRECATED= Qt4 has been EOL since december 2015
-EXPIRATION_DATE= 2019-03-15
-
# Avoid clash with libssh from base
BUILD_DEPENDS= ${LOCALBASE}/lib/libssh.so:security/libssh
LIB_DEPENDS= libcups.so:print/cups \
@@ -24,10 +20,11 @@ LIB_DEPENDS= libcups.so:print/cups \
RUN_DEPENDS= nxproxy:net/nxproxy \
x2goclient-cli:net/x2goclient-cli
-USES= qmake qt:4
+USES= gl qmake qt:5
+USE_GL= gl
USE_XORG= x11 xpm
-USE_QT= corelib gui network svg \
- linguisttools_build moc_build rcc_build uic_build
+USE_QT= core gui network svg widgets x11extras \
+ buildtools_build linguisttools_build qmake_build
QMAKE_ARGS= QMAKE_LRELEASE="${LRELEASE}"
OPTIONS_DEFINE= DOCS LDAP