aboutsummaryrefslogtreecommitdiffstats
path: root/net/xmlrpc-c
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2012-06-30 04:48:43 +0800
committergarga <garga@FreeBSD.org>2012-06-30 04:48:43 +0800
commit2bbc8c94eea4475dce0fd3b8e8a77a24b9113f3f (patch)
tree671c84ce6377df3bd6c23db69c3630b67438f14f /net/xmlrpc-c
parent14160085b79e7476a73cb9f3f14413816dae1fda (diff)
downloadfreebsd-ports-gnome-2bbc8c94eea4475dce0fd3b8e8a77a24b9113f3f.tar.gz
freebsd-ports-gnome-2bbc8c94eea4475dce0fd3b8e8a77a24b9113f3f.tar.zst
freebsd-ports-gnome-2bbc8c94eea4475dce0fd3b8e8a77a24b9113f3f.zip
- Move to OPTIONSng
- Pet portlint
Diffstat (limited to 'net/xmlrpc-c')
-rw-r--r--net/xmlrpc-c/Makefile25
1 files changed, 13 insertions, 12 deletions
diff --git a/net/xmlrpc-c/Makefile b/net/xmlrpc-c/Makefile
index 264988ea1017..0b94bbac2eaf 100644
--- a/net/xmlrpc-c/Makefile
+++ b/net/xmlrpc-c/Makefile
@@ -15,9 +15,12 @@ EXTRACT_SUFX= .tgz
MAINTAINER= garga@FreeBSD.org
COMMENT= XML-RPC library for C and C++
-OPTIONS= DEBUG "Compile with debugging information" off \
- CURL "Compile with curl support" on \
- LIBWWW "Compile with libwww support" on
+LICENSE= BSD
+
+OPTIONS_DEFINE= DEBUG CURL LIBWWW
+OPTIONS_DEFAULT=CURL LIBWWW
+
+LIBWWW_DESC= Compile with libwww support
CONFLICTS= xmlrpc-epi-0.* xmlrpc-c-devel-[0-9]*
@@ -31,31 +34,29 @@ MAKE_ARGS= LIBTOOL="${LIBTOOL}" \
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
-LICENSE= BSD
-
.include <bsd.port.pre.mk>
-.if !defined(WITH_DEBUG)
+.if empty(PORT_OPTIONS:MDEBUG)
CFLAGS+= -DNDEBUG
.endif
-.if defined(WITH_CURL)
-LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
+.if ${PORT_OPTIONS:MCURL}
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+= --enable-curl-client
.else
CONFIGURE_ARGS+= --disable-curl-client
.endif
-.if defined(WITH_LIBWWW)
-LIB_DEPENDS+= wwwcore.1:${PORTSDIR}/www/libwww
+.if ${PORT_OPTIONS:MLIBWWW}
+LIB_DEPENDS+= wwwcore:${PORTSDIR}/www/libwww
CONFIGURE_ARGS+= --enable-libwww-client
.else
CONFIGURE_ARGS+= --disable-libwww-client
.endif
post-extract:
- @${FIND} ${WRKSRC} -type l -name blddir | ${XARGS} ${RM}
- @${FIND} ${WRKSRC} -type l -name srcdir | ${XARGS} ${RM}
+ @${FIND} ${WRKSRC} -type l -name blddir -delete
+ @${FIND} ${WRKSRC} -type l -name srcdir -delete
post-patch:
@${GREP} -lR '\-lpthread' ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \