aboutsummaryrefslogtreecommitdiffstats
path: root/net/ysm/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-10-08 20:53:01 +0800
committerkrion <krion@FreeBSD.org>2003-10-08 20:53:01 +0800
commitbb202d9b745df50f2b39db32c0c7a0714666c199 (patch)
tree5cef798c3c00844e6e2c67acf9d12ec0c7c9bfec /net/ysm/Makefile
parent45f93575b8b2f36d0f2cba7c6eae1b64c9443191 (diff)
downloadfreebsd-ports-gnome-bb202d9b745df50f2b39db32c0c7a0714666c199.tar.gz
freebsd-ports-gnome-bb202d9b745df50f2b39db32c0c7a0714666c199.tar.zst
freebsd-ports-gnome-bb202d9b745df50f2b39db32c0c7a0714666c199.zip
- Update to 7.2.9.1
PR: 57740 Submitted by: Evgueni V. Gavrilov <aquatique@rusunix.org> (maintainer)
Diffstat (limited to 'net/ysm/Makefile')
-rw-r--r--net/ysm/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/net/ysm/Makefile b/net/ysm/Makefile
index 2814ac1cf094..269e02ca51d9 100644
--- a/net/ysm/Makefile
+++ b/net/ysm/Makefile
@@ -6,20 +6,21 @@
#
PORTNAME= ysm
-PORTVERSION= 7.2.9.0
+PORTVERSION= 7.2.9.1
PORTREVISION= 0
CATEGORIES= net
MASTER_SITES= ftp://rusunix.org/pub/FreeBSD/distfiles/ \
http://aquatique.rusunix.org/ \
${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ysmv7_2_9_0
+DISTNAME= ${PORTNAME}v${PORTVERSION:S/./_/g}
MAINTAINER= aquatique@rusunix.org
COMMENT= Command line ICQ client with ICQ2000 and recoding support
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
+USE_REINPLACE= yes
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -29,4 +30,8 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
MAN1= ysm.1
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+
.include <bsd.port.mk>