aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2010-06-30 15:20:39 +0800
committerdelphij <delphij@FreeBSD.org>2010-06-30 15:20:39 +0800
commit0129daf02f909349f4c336266bd8a7445b612b12 (patch)
tree29d3c82189c4e1cb02dabe45e399c747866f01ac /net
parentcc92295e22583128420662ff286e2e41e9b121d7 (diff)
downloadfreebsd-ports-gnome-0129daf02f909349f4c336266bd8a7445b612b12.tar.gz
freebsd-ports-gnome-0129daf02f909349f4c336266bd8a7445b612b12.tar.zst
freebsd-ports-gnome-0129daf02f909349f4c336266bd8a7445b612b12.zip
- SASL is not default since 2007 so remove an unneeded test about WITHOUT_SASL
which causes confusion that defining WITHOUT_SASL as building openldap24-sasl-client would get you openldap24-client. - Add an option to build without fetch(3) library, which in turn depends on base OpenSSL. [1] - Promote SASL and FETCH options to be on both client and library ports. - Both SASL and FETCH remains their defaults (no and yes) so no PORTREVISION bump. PR: ports/145337 [1] Feature safe: yes
Diffstat (limited to 'net')
-rw-r--r--net/openldap24-server/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index ea98b3f21a90..fa6ab0ddafaf 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -42,9 +42,11 @@ BROKEN= incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}
PORTREVISION_CLIENT= 0
PORTREVISION_SERVER= 0
-.if !defined(CLIENT_ONLY)
OPTIONS= SASL "With (Cyrus) SASL2 support" off \
- DYNACL "Run-time loadable ACL (experimental)" off \
+ FETCH "Enable fetch(3) support" on
+
+.if !defined(CLIENT_ONLY)
+OPTIONS+= DYNACL "Run-time loadable ACL (experimental)" off \
ACI "Per-object ACI (experimental)" off \
DNSSRV "With Dnssrv backend" off \
PASSWD "With Passwd backend" off \
@@ -95,7 +97,7 @@ CONFIGURE_SED= -e 's,-kthread,${PTHREAD_LIBS},g' -e 's,uuid/uuid.h,xxuuid/uuid.
.include <bsd.port.pre.mk>
.if defined(CLIENT_ONLY)
-.if defined(WITH_SASL) && !defined(WITHOUT_SASL)
+.if defined(WITH_SASL)
PKGNAMESUFFIX= -sasl-client
COMMENT= Open source LDAP client implementation with SASL2 support
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.* \
@@ -116,7 +118,7 @@ BROKEN= You have `USE_OPENLDAP' variable defined either in environment or in m
USE_OPENLDAP= yes
WANT_OPENLDAP_VER= 24
-.if defined(WITH_SASL) && !defined(WITHOUT_SASL)
+.if defined(WITH_SASL)
WANT_OPENLDAP_SASL= yes
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-client-2.*
PKGNAMESUFFIX= -sasl-server
@@ -147,7 +149,11 @@ CONFIGURE_ARGS= --with-threads=posix \
--with-tls=openssl \
--enable-dynamic
-.if defined(WITH_SASL) && !defined(WITHOUT_SASL)
+.if defined(WITHOUT_FETCH)
+CONFIGURE_ARGS+= --without-fetch
+.endif
+
+.if defined(WITH_SASL)
LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
CONFIGURE_ARGS+= --with-cyrus-sasl
.else
@@ -378,7 +384,7 @@ PLIST_SUB+= BACK_PERL=${BACKEND_PLIST}
PLIST_SUB+= BACK_PERL="@comment "
.endif
-.if defined(WITH_SASL) && !defined(WITHOUT_SASL)
+.if defined(WITH_SASL)
CONFIGURE_ARGS+= --enable-spasswd
.endif