aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2013-10-21 07:48:06 +0800
committerswills <swills@FreeBSD.org>2013-10-21 07:48:06 +0800
commit016286a93e9821e4c93d3b56d5407f5f92f244fd (patch)
tree269d58dcc7bf93ac96662e4458f5c3be386c013a /net
parentffaa733ef0fce4baa7dc84ec1af647d923dea6b2 (diff)
downloadfreebsd-ports-gnome-016286a93e9821e4c93d3b56d5407f5f92f244fd.tar.gz
freebsd-ports-gnome-016286a93e9821e4c93d3b56d5407f5f92f244fd.tar.zst
freebsd-ports-gnome-016286a93e9821e4c93d3b56d5407f5f92f244fd.zip
A generic OAuth (1.0/1.0a) strategy for OmniAuth.
WWW: https://github.com/intridea/omniauth-oauth PR: ports/182697 Submitted by: Loic Blot <loic.blot@unix-experience.fr>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-omniauth-oauth/Makefile20
-rw-r--r--net/rubygem-omniauth-oauth/distinfo2
-rw-r--r--net/rubygem-omniauth-oauth/pkg-descr3
4 files changed, 26 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index e7041c5cdb77..bad3741749a3 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1040,6 +1040,7 @@
SUBDIR += rubygem-network_interface
SUBDIR += rubygem-oauth
SUBDIR += rubygem-oauth2
+ SUBDIR += rubygem-omniauth-oauth
SUBDIR += rubygem-open-uri-cached
SUBDIR += rubygem-openid
SUBDIR += rubygem-packetfu
diff --git a/net/rubygem-omniauth-oauth/Makefile b/net/rubygem-omniauth-oauth/Makefile
new file mode 100644
index 000000000000..197d932ca3e9
--- /dev/null
+++ b/net/rubygem-omniauth-oauth/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= omniauth-oauth
+PORTVERSION= 1.0.1
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Generic OAuth strategy for OmniAuth
+
+RUN_DEPENDS= rubygem-oauth>=0:${PORTSDIR}/net/rubygem-oauth \
+ rubygem-omniauth>=1.0:${PORTSDIR}/security/rubygem-omniauth
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+NO_STAGE= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-omniauth-oauth/distinfo b/net/rubygem-omniauth-oauth/distinfo
new file mode 100644
index 000000000000..30ab285d561f
--- /dev/null
+++ b/net/rubygem-omniauth-oauth/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/omniauth-oauth-1.0.1.gem) = 9f1bfb30fe6ba823935330d2036e08a5406e980f1e20c9b1271b82ee34fbe759
+SIZE (rubygem/omniauth-oauth-1.0.1.gem) = 8192
diff --git a/net/rubygem-omniauth-oauth/pkg-descr b/net/rubygem-omniauth-oauth/pkg-descr
new file mode 100644
index 000000000000..489192cb56ba
--- /dev/null
+++ b/net/rubygem-omniauth-oauth/pkg-descr
@@ -0,0 +1,3 @@
+A generic OAuth (1.0/1.0a) strategy for OmniAuth.
+
+WWW: https://github.com/intridea/omniauth-oauth