aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2000-10-23 18:50:06 +0800
committerjeh <jeh@FreeBSD.org>2000-10-23 18:50:06 +0800
commit03a425dcbb0185431be5e28cce269a70c50d014e (patch)
tree6195c69f99a0dc3534135d08da48bfb533dc05dc /net
parent17da48f8a47c33fff51d3df6c8cc7ed202ce756b (diff)
downloadfreebsd-ports-gnome-03a425dcbb0185431be5e28cce269a70c50d014e.tar.gz
freebsd-ports-gnome-03a425dcbb0185431be5e28cce269a70c50d014e.tar.zst
freebsd-ports-gnome-03a425dcbb0185431be5e28cce269a70c50d014e.zip
Add port net/ghtool
A command-line interface to the resolver library PR: 21396 Submitted by: Peter Pentchev <roam@orbitel.bg> MAINTAINER
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/ghtool/Makefile33
-rw-r--r--net/ghtool/distinfo1
-rw-r--r--net/ghtool/pkg-comment1
-rw-r--r--net/ghtool/pkg-descr11
-rw-r--r--net/ghtool/pkg-plist1
6 files changed, 48 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 743c45670f32..a1b5b632b08a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -75,6 +75,7 @@
SUBDIR += gatekeeper
SUBDIR += generic-nqs
SUBDIR += ggsd
+ SUBDIR += ghtool
SUBDIR += gicq
SUBDIR += gkrellm_snmp
SUBDIR += gnet
diff --git a/net/ghtool/Makefile b/net/ghtool/Makefile
new file mode 100644
index 000000000000..94d4feda10e9
--- /dev/null
+++ b/net/ghtool/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: ghtool
+# Date created: 19 September 2000
+# Whom: roam@orbitel.bg
+#
+# $FreeBSD$
+#
+
+PORTNAME= ghtool
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=gh-tool
+DISTNAME= ghmain.c
+EXTRACT_SUFX=
+
+MAINTAINER= roam@orbitel.bg
+
+WRKSRC= ${WRKDIR}
+
+TGT= gh
+SRC= gh.c
+
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= ${WRKSRC}/${SRC}
+
+do-build:
+ ${CC} ${CFLAGS} -o ${WRKSRC}/${TGT} ${WRKSRC}/${SRC}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${TGT} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/ghtool/distinfo b/net/ghtool/distinfo
new file mode 100644
index 000000000000..1bf4b13546ca
--- /dev/null
+++ b/net/ghtool/distinfo
@@ -0,0 +1 @@
+MD5 (ghmain.c) = 063690f107086022b111648b73cad036
diff --git a/net/ghtool/pkg-comment b/net/ghtool/pkg-comment
new file mode 100644
index 000000000000..111745d590f9
--- /dev/null
+++ b/net/ghtool/pkg-comment
@@ -0,0 +1 @@
+A command-line interface to the resolver library
diff --git a/net/ghtool/pkg-descr b/net/ghtool/pkg-descr
new file mode 100644
index 000000000000..b8f7345dad15
--- /dev/null
+++ b/net/ghtool/pkg-descr
@@ -0,0 +1,11 @@
+To quote from the SourceForge project description:
+
+ gh-tool is a command-line interface to gethostby*, in libresolv/libc.
+ It allows one to check the local system's notion of an IP->DNS or
+ DNS->IP mapping, including aliases, directly, rather than digging for
+ mappings in DNS, which may or may not be relevant.
+
+WWW: http://www.sourceforge.net/projects/gh-tool/
+Author: Ally Kendall <aminorex@users.sourceforge.net>
+
+Maintainer: Peter Pentchev <roam@orbitel.bg>
diff --git a/net/ghtool/pkg-plist b/net/ghtool/pkg-plist
new file mode 100644
index 000000000000..eee25483706d
--- /dev/null
+++ b/net/ghtool/pkg-plist
@@ -0,0 +1 @@
+bin/gh