aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-09-02 22:54:28 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-09-02 22:54:28 +0800
commit0497868f5335c3bc16446e36d049ccaf52538d6f (patch)
treef1d25abe5187af24ab44a6119f1ef4309dc7e8f1 /net
parent39571f569163b1a41c51036198f4e4f64448c502 (diff)
downloadfreebsd-ports-gnome-0497868f5335c3bc16446e36d049ccaf52538d6f.tar.gz
freebsd-ports-gnome-0497868f5335c3bc16446e36d049ccaf52538d6f.tar.zst
freebsd-ports-gnome-0497868f5335c3bc16446e36d049ccaf52538d6f.zip
- Switch to USES=libedit as suggested by stage-qa
- Switch to options helpers Approved by: portmgr blanket
Diffstat (limited to 'net')
-rw-r--r--net/ntp/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index d0cedf44fba8..61a6b4a7809f 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ntp
PORTVERSION= 4.2.8p3
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ \
http://archive.ntp.org/ntp4/ntp-4.2/ \
@@ -16,7 +17,7 @@ CONFLICTS= ntp-rc-* ntp-devel-*
GNU_CONFIGURE= yes
OPTIONS_SUB= yes
-USES= cpe pathfix shebangfix libtool pkgconfig
+USES= cpe pathfix shebangfix libedit libtool pkgconfig
LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
SHEBANG_FILES= scripts/ntptrace/ntptrace.in \
@@ -37,17 +38,11 @@ NTP_SIGND_CONFIGURE_ENABLE= ntp-signd
NTPSNMPD_LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
NTPSNMPD_CONFIGURE_OFF= --without-ntpsnmpd
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MSSL}
-CONFIGURE_ARGS+= --with-openssl-incdir=${OPENSSLINC} \
+SSL_CONFIGURE_ON= --with-openssl-incdir=${OPENSSLINC} \
--with-openssl-libdir=${OPENSSLLIB}
-.endif
.for D in ${NTP_DRIVERS}
-.if ${PORT_OPTIONS:M${D}}
-CONFIGURE_ARGS+= --enable-${D}
-.endif
+${D}_CONFIGURE_ON= --enable-${D}
.endfor
# XXX Temporary hack. Remember to remove this next commit.
@@ -63,4 +58,4 @@ post-install:
@cd ${WRKSRC}/html && ${FIND} . -print | \
${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} --quiet ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>