aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-05-07 10:23:55 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-05-07 10:23:55 +0800
commit0814281defdd43513080809c0506f52575a716b5 (patch)
tree823cdf876d3b23466a29b5de32dcaa776fba13c9 /net
parent7ed6f929ee767f9eb4034e7c4fdafe479a83e6e8 (diff)
downloadfreebsd-ports-gnome-0814281defdd43513080809c0506f52575a716b5.tar.gz
freebsd-ports-gnome-0814281defdd43513080809c0506f52575a716b5.tar.zst
freebsd-ports-gnome-0814281defdd43513080809c0506f52575a716b5.zip
Simpleproxy program acts as simple tcp proxy. It listens for local
socket, and any connection to this port will be forwarded to another socket at remote host. WWW: http://www.crocodile.org/software.html PR: 134266 Submitted by: pluknet <pluknet at gmail dot com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/simpleproxy/Makefile24
-rw-r--r--net/simpleproxy/distinfo3
-rw-r--r--net/simpleproxy/pkg-descr7
4 files changed, 35 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index cdc1a4ee1a4f..cdeedd1d3812 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -883,6 +883,7 @@
SUBDIR += silc-client
SUBDIR += silc-irssi-plugin
SUBDIR += silc-server
+ SUBDIR += simpleproxy
SUBDIR += sip_scenario
SUBDIR += siproxd
SUBDIR += sipsak
diff --git a/net/simpleproxy/Makefile b/net/simpleproxy/Makefile
new file mode 100644
index 000000000000..e9c8c0f9f1c5
--- /dev/null
+++ b/net/simpleproxy/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: simpleproxy
+# Date created: 06 May 2009
+# Whom: Sergey Kandaurov <pluknet@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= simpleproxy
+PORTVERSION= 3.4
+CATEGORIES= net
+MASTER_SITES= SF
+
+MAINTAINER= pluknet@gmail.com
+COMMENT= Simple tcp proxy
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/${PORTNAME}
+
+.if !defined(NO_INSTALL_MANPAGES)
+MAN1= simpleproxy.1
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/simpleproxy/distinfo b/net/simpleproxy/distinfo
new file mode 100644
index 000000000000..5d472854630c
--- /dev/null
+++ b/net/simpleproxy/distinfo
@@ -0,0 +1,3 @@
+MD5 (simpleproxy-3.4.tar.gz) = 95fbc83e731f4c727802e023cf3d43ad
+SHA256 (simpleproxy-3.4.tar.gz) = 194b280251edc16f1930dca6e2742c3f353523bc735c7a9d3d1a4d23ca09a74c
+SIZE (simpleproxy-3.4.tar.gz) = 31904
diff --git a/net/simpleproxy/pkg-descr b/net/simpleproxy/pkg-descr
new file mode 100644
index 000000000000..d8d9e778ba38
--- /dev/null
+++ b/net/simpleproxy/pkg-descr
@@ -0,0 +1,7 @@
+Simpleproxy program acts as simple tcp proxy. It listens for local
+socket, and any connection to this port will be forwarded to another
+socket at remote host.
+
+LICENSE: GPL2 or later
+
+WWW: http://www.crocodile.org/software.html