aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-08-29 06:03:42 +0800
committerkrion <krion@FreeBSD.org>2003-08-29 06:03:42 +0800
commit08fc8d9bbc07da9f4ec949319c240684cccae507 (patch)
tree6189c5fe1590d8e06e3c73e20afd1871dd4a8061 /net
parentea013142a7d8d9305790ee0c93c1a60829904ff0 (diff)
downloadfreebsd-ports-gnome-08fc8d9bbc07da9f4ec949319c240684cccae507.tar.gz
freebsd-ports-gnome-08fc8d9bbc07da9f4ec949319c240684cccae507.tar.zst
freebsd-ports-gnome-08fc8d9bbc07da9f4ec949319c240684cccae507.zip
- New port: eChat - Serverless LAN chat
eChat is a LAN chat program designed for easy chat and messages exchange over the TCP/IP networks PR: 55994 Submitted by: SeaD <sead@deep.perm.ru>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/echat/Makefile34
-rw-r--r--net/echat/distinfo1
-rw-r--r--net/echat/pkg-descr7
-rw-r--r--net/echat/pkg-plist2
5 files changed, 45 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 7e40a143879a..6cd453bf7f0a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -128,6 +128,7 @@
SUBDIR += dtcp
SUBDIR += dtcpclient
SUBDIR += easysoap
+ SUBDIR += echat
SUBDIR += echolot
SUBDIR += echoping
SUBDIR += edonkey-gui-gtk
diff --git a/net/echat/Makefile b/net/echat/Makefile
new file mode 100644
index 000000000000..c180419b66a5
--- /dev/null
+++ b/net/echat/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: echat
+# Date created: 26 Aug 2003
+# Whom: SeaD
+#
+# $FreeBSD$
+#
+
+PORTNAME= echat
+PORTVERSION= 0.02f2
+CATEGORIES= net
+MASTER_SITES= http://echat.deep.perm.ru/files/
+
+MAINTAINER= sead@mail.ru
+COMMENT= LAN chat program over the TCP/IP networks
+
+USE_REINPLACE= yes
+
+MAN1= echat.1
+
+post-patch:
+ ${REINPLACE_CMD} -e \
+ 's|^CFLAGS=|CFLAGS+=|g ; \
+ s|PREFIX=/usr/local|PREFIX=${PREFIX}|g ; \
+ s|CC=|CC?=|g' \
+ ${WRKSRC}/Makefile
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/.echatrc.sample ${PREFIX}/etc/echatrc.sample
+ @${ECHO} "======================================================================"
+ @${ECHO} " Please put \"${PREFIX}/etc/echatrc.sample\" in the right place."
+ @${ECHO} " eChat will search in \"~/.echatrc\". Then edit it as you want."
+ @${ECHO} "======================================================================"
+
+.include <bsd.port.mk>
diff --git a/net/echat/distinfo b/net/echat/distinfo
new file mode 100644
index 000000000000..17c6865c0b64
--- /dev/null
+++ b/net/echat/distinfo
@@ -0,0 +1 @@
+MD5 (echat-0.02f2.tar.gz) = 11c72a33ba88fa4a3547ad02d58eff0e
diff --git a/net/echat/pkg-descr b/net/echat/pkg-descr
new file mode 100644
index 000000000000..4336db9c93f7
--- /dev/null
+++ b/net/echat/pkg-descr
@@ -0,0 +1,7 @@
+eChat is a LAN chat program designed for easy
+chat and messages exchange over the TCP/IP networks
+
+compatible with Vypress Chat and quickChat for Win32
+
+Author SeaD <sead@mail.ru>
+WWW: http://echat.deep.perm.ru/
diff --git a/net/echat/pkg-plist b/net/echat/pkg-plist
new file mode 100644
index 000000000000..fe997eb64381
--- /dev/null
+++ b/net/echat/pkg-plist
@@ -0,0 +1,2 @@
+bin/echat
+etc/echatrc.sample