aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-05-22 16:51:00 +0800
committerWen Heping <wen@FreeBSD.org>2010-05-22 16:51:00 +0800
commit09217780f856f7a116ffa9195f149866c2dfe99d (patch)
treee520d226bb89c98932eed9a27dcd084a8e2d9438 /net
parent92f568731c60d2ab2373c5b6c3a60c380a51ef48 (diff)
downloadfreebsd-ports-gnome-09217780f856f7a116ffa9195f149866c2dfe99d.tar.gz
freebsd-ports-gnome-09217780f856f7a116ffa9195f149866c2dfe99d.tar.zst
freebsd-ports-gnome-09217780f856f7a116ffa9195f149866c2dfe99d.zip
- Fix the build error reported by QAT@
PR: ports/146809 Submitted by: Sten Spans <sten@blinkenlights.nl> (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/ladvd/Makefile1
-rw-r--r--net/ladvd/files/patch-ifdescr-semicolon11
2 files changed, 12 insertions, 0 deletions
diff --git a/net/ladvd/Makefile b/net/ladvd/Makefile
index 97bcfabd48cb..a477e6aabe44 100644
--- a/net/ladvd/Makefile
+++ b/net/ladvd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ladvd
PORTVERSION= 0.9.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://blinkenlights.nl/software/ladvd/
diff --git a/net/ladvd/files/patch-ifdescr-semicolon b/net/ladvd/files/patch-ifdescr-semicolon
new file mode 100644
index 000000000000..d3c02d4b11fe
--- /dev/null
+++ b/net/ladvd/files/patch-ifdescr-semicolon
@@ -0,0 +1,11 @@
+--- src/netif.c.orig 2010-05-21 23:59:23.000000000 +0200
++++ src/netif.c 2010-05-21 23:59:36.000000000 +0200
+@@ -264,7 +264,7 @@
+ #ifndef __FreeBSD__
+ ifr.ifr_data = (caddr_t)&netif->description;
+ #else
+- ifr.ifr_buffer.buffer = &netif->description
++ ifr.ifr_buffer.buffer = &netif->description;
+ ifr.ifr_buffer.length = IFDESCRSIZE;
+ #endif
+ ioctl(sockfd, SIOCGIFDESCR, &ifr);