aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2012-01-25 22:39:34 +0800
committerculot <culot@FreeBSD.org>2012-01-25 22:39:34 +0800
commit097da09217bb80330c264e12318d638aba723cd7 (patch)
tree9d2ae11e8ac2a345a7e18cf227dcd57049da4193 /net
parent34c3ad67cda6bdb9d10065bb052be0ab8b324388 (diff)
downloadfreebsd-ports-gnome-097da09217bb80330c264e12318d638aba723cd7.tar.gz
freebsd-ports-gnome-097da09217bb80330c264e12318d638aba723cd7.tar.zst
freebsd-ports-gnome-097da09217bb80330c264e12318d638aba723cd7.zip
Net::Server::SS::PreFork is a hot-deployable variant of Net::Server::PreFork.
WWW: http://search.cpan.org/dist/Net-Server-SS-PreFork/ PR: ports/164411 (based on) Submitted by: Denis Pokataev <catone@cpan.org>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Server-SS-PreFork/Makefile33
-rw-r--r--net/p5-Net-Server-SS-PreFork/distinfo2
-rw-r--r--net/p5-Net-Server-SS-PreFork/pkg-descr3
-rw-r--r--net/p5-Net-Server-SS-PreFork/pkg-plist9
5 files changed, 48 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index a00a0fc4807c..f36011f80e0c 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -643,6 +643,7 @@
SUBDIR += p5-Net-SSH2
SUBDIR += p5-Net-Server
SUBDIR += p5-Net-Server-Coro
+ SUBDIR += p5-Net-Server-SS-PreFork
SUBDIR += p5-Net-Services
SUBDIR += p5-Net-Subnet
SUBDIR += p5-Net-Subnets
diff --git a/net/p5-Net-Server-SS-PreFork/Makefile b/net/p5-Net-Server-SS-PreFork/Makefile
new file mode 100644
index 000000000000..6b09a4d2bd5c
--- /dev/null
+++ b/net/p5-Net-Server-SS-PreFork/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Net-Server-SS-PreFork
+# Date created: 2012-01-21
+# Whom: Denis Pokataev <catone@cpan.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Server-SS-PreFork
+PORTVERSION= 0.05
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= catone@cpan.org
+COMMENT= A hot-deployable variant of Net::Server::PreFork
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Net-Server>0:${PORTSDIR}/net/p5-Net-Server \
+ p5-Server-Starter>=0.02:${PORTSDIR}/net/p5-Server-Starter
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+TEST_DEPENDS= p5-HTTP-Server-Simple>0:${PORTSDIR}/www/p5-HTTP-Server-Simple \
+ p5-Test-SharedFork>0:${PORTSDIR}/devel/p5-Test-SharedFork \
+ p5-Test-TCP>=0.06:${PORTSDIR}/devel/p5-Test-TCP \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Server::SS::PreFork.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Server-SS-PreFork/distinfo b/net/p5-Net-Server-SS-PreFork/distinfo
new file mode 100644
index 000000000000..8f957b974893
--- /dev/null
+++ b/net/p5-Net-Server-SS-PreFork/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-Server-SS-PreFork-0.05.tar.gz) = 6d22b3a84eb3e01fb238f566bdb3014847d30e0d51ec1e86a0b6e043e367968b
+SIZE (Net-Server-SS-PreFork-0.05.tar.gz) = 25978
diff --git a/net/p5-Net-Server-SS-PreFork/pkg-descr b/net/p5-Net-Server-SS-PreFork/pkg-descr
new file mode 100644
index 000000000000..e7789b4bf476
--- /dev/null
+++ b/net/p5-Net-Server-SS-PreFork/pkg-descr
@@ -0,0 +1,3 @@
+A hot-deployable variant of Net::Server::PreFork.
+
+WWW: http://search.cpan.org/dist/Net-Server-SS-PreFork/
diff --git a/net/p5-Net-Server-SS-PreFork/pkg-plist b/net/p5-Net-Server-SS-PreFork/pkg-plist
new file mode 100644
index 000000000000..7ddf73816513
--- /dev/null
+++ b/net/p5-Net-Server-SS-PreFork/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Net/Server/SS/PreFork.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Server/SS/PreFork/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Server/SS/PreFork
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Server/SS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Server
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/Server/SS
+@dirrmtry %%SITE_PERL%%/Net/Server
+@dirrmtry %%SITE_PERL%%/Net