aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-07-28 22:11:27 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-07-28 22:11:27 +0800
commit0991ae43eee5197af725b37c3b6d6124489443f8 (patch)
tree6ab863b88ee505ab52b730adc39fd85047fce824 /net
parent71f1f0c7136129db0f8c131e43f126f485a7e21b (diff)
downloadfreebsd-ports-gnome-0991ae43eee5197af725b37c3b6d6124489443f8.tar.gz
freebsd-ports-gnome-0991ae43eee5197af725b37c3b6d6124489443f8.tar.zst
freebsd-ports-gnome-0991ae43eee5197af725b37c3b6d6124489443f8.zip
- Fix a Python import when importing of a pcap file in scapy
PR: 136798, 136924 Submitted by: Aurélien Ansel <aurelien.ansel@netasq.com> Approved by: VANHULLEBUS Yvan <vanhu@netasq.com> (maintainer via private email)
Diffstat (limited to 'net')
-rw-r--r--net/scapy/Makefile2
-rw-r--r--net/scapy/files/patch-scapy-sendrecv.py11
2 files changed, 12 insertions, 1 deletions
diff --git a/net/scapy/Makefile b/net/scapy/Makefile
index 24de010f3ef9..f7c9d6960a52 100644
--- a/net/scapy/Makefile
+++ b/net/scapy/Makefile
@@ -8,7 +8,7 @@
PORTNAME= scapy
PORTVERSION= 2.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://secdev.org/projects/scapy/files/
diff --git a/net/scapy/files/patch-scapy-sendrecv.py b/net/scapy/files/patch-scapy-sendrecv.py
new file mode 100644
index 000000000000..e44447c0ccc5
--- /dev/null
+++ b/net/scapy/files/patch-scapy-sendrecv.py
@@ -0,0 +1,11 @@
+--- scapy/sendrecv.py.orig 2009-07-15 18:19:31.000000000 +0200
++++ scapy/sendrecv.py 2009-07-15 18:19:46.000000000 +0200
+@@ -9,7 +9,7 @@
+ from arch import *
+ from config import conf
+ from packet import Gen
+-from utils import warning
++from utils import warning,PcapReader
+ import plist
+ from error import log_runtime,log_interactive
+