aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2005-04-25 17:05:26 +0800
committersobomax <sobomax@FreeBSD.org>2005-04-25 17:05:26 +0800
commit09d3411df0bdfce1ed6e408cfca8bdf4167ed843 (patch)
treee96e429950aa68fbc019076cf397a25e3a60c55c /net
parent1944e20add618a8b86e03bbcace816125d524afd (diff)
downloadfreebsd-ports-gnome-09d3411df0bdfce1ed6e408cfca8bdf4167ed843.tar.gz
freebsd-ports-gnome-09d3411df0bdfce1ed6e408cfca8bdf4167ed843.tar.zst
freebsd-ports-gnome-09d3411df0bdfce1ed6e408cfca8bdf4167ed843.zip
Make sure zaptel module loaded first and unloaded last, since all other
modules depend on it. Bump PORTREVISION. Submitted by: Ryan J. Taylor <rj@rjt.org>
Diffstat (limited to 'net')
-rw-r--r--net/zaptel12/Makefile1
-rw-r--r--net/zaptel12/files/zaptel.sh4
2 files changed, 3 insertions, 2 deletions
diff --git a/net/zaptel12/Makefile b/net/zaptel12/Makefile
index 43ae89f3a9b2..e30ab6e77158 100644
--- a/net/zaptel12/Makefile
+++ b/net/zaptel12/Makefile
@@ -7,6 +7,7 @@
PORTNAME= zaptel
PORTVERSION= 0.9
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://www.portaone.com/~sobomax/
DISTNAME= ${PORTNAME}-freebsd-${PORTVERSION}
diff --git a/net/zaptel12/files/zaptel.sh b/net/zaptel12/files/zaptel.sh
index d2f5e60b61fc..e2ccf1e7a6a8 100644
--- a/net/zaptel12/files/zaptel.sh
+++ b/net/zaptel12/files/zaptel.sh
@@ -5,8 +5,8 @@ LIBDIR=${PREFIX}/lib/zaptel
case "$1" in
start)
- /sbin/kldload ${LIBDIR}/qozap.ko || exit 1
/sbin/kldload ${LIBDIR}/zaptel.ko || exit 1
+ /sbin/kldload ${LIBDIR}/qozap.ko || exit 1
/sbin/kldload ${LIBDIR}/wcfxo.ko || exit 1
/sbin/kldload ${LIBDIR}/wcfxs.ko || exit 1
/sbin/kldload ${LIBDIR}/wct1xxp.ko || exit 1
@@ -19,10 +19,10 @@ case "$1" in
/sbin/kldunload qozap.ko || exit 1
/sbin/kldunload wcfxs.ko || exit 1
/sbin/kldunload wcfxo.ko || exit 1
- /sbin/kldunload zaptel.ko || exit 1
/sbin/kldunload wct1xxp.ko || exit 1
/sbin/kldunload wct4xxp.ko || exit 1
/sbin/kldunload wcte11xp.ko || exit 1
+ /sbin/kldunload zaptel.ko || exit 1
echo -n " zaptel"
;;