aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2019-08-18 19:31:10 +0800
committerpi <pi@FreeBSD.org>2019-08-18 19:31:10 +0800
commit0f207d55f2c2026d59c89353698d64fae710c184 (patch)
tree179452553e5d0143d809769e71fe66003f4f6c48 /net
parent89945557a0e1fb9899b031d44de527c18a2fa777 (diff)
downloadfreebsd-ports-gnome-0f207d55f2c2026d59c89353698d64fae710c184.tar.gz
freebsd-ports-gnome-0f207d55f2c2026d59c89353698d64fae710c184.tar.zst
freebsd-ports-gnome-0f207d55f2c2026d59c89353698d64fae710c184.zip
New port: net/socketapi
SocketAPI is the socket API library for the SCTPLIB user-space SCTP implementation. WWW: https://www.uni-due.de/~be0001/sctplib/ PR: 239848 Submitted by: Thomas Dreibholz <dreibh@iem.uni-due.de>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/socketapi/Makefile26
-rw-r--r--net/socketapi/distinfo3
-rw-r--r--net/socketapi/pkg-descr4
-rw-r--r--net/socketapi/pkg-plist42
5 files changed, 76 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 394ddbcef8a5..1174ffe4e392 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1383,6 +1383,7 @@
SUBDIR += sobby
SUBDIR += socat
SUBDIR += sock
+ SUBDIR += socketapi
SUBDIR += socketbind
SUBDIR += socketpipe
SUBDIR += socketw
diff --git a/net/socketapi/Makefile b/net/socketapi/Makefile
new file mode 100644
index 000000000000..643aeabfcdfb
--- /dev/null
+++ b/net/socketapi/Makefile
@@ -0,0 +1,26 @@
+# Created by: Thomas Dreibholz <dreibh@iem.uni-due.de>
+# $FreeBSD$
+
+PORTNAME= socketapi
+PORTVERSION= 2.2.16
+CATEGORIES= net
+MASTER_SITES= https://www.uni-due.de/~be0001/sctplib/download/
+
+MAINTAINER= dreibh@iem.uni-due.de
+COMMENT= Socket API library for the SCTPLIB user-space SCTP implementation
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libsctplib.so:net/sctplib
+
+USES= gnome libtool pkgconfig
+USE_LDCONFIG= yes
+USE_GNOME= glib20
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --enable-sctp-over-udp
+LDFLAGS+= -L${LOCALBASE}/lib -lsctplib
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>
diff --git a/net/socketapi/distinfo b/net/socketapi/distinfo
new file mode 100644
index 000000000000..d70d9133f011
--- /dev/null
+++ b/net/socketapi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1565784291
+SHA256 (socketapi-2.2.16.tar.gz) = f29d324e1b7b2743d80d4c493c56d56eebdd1166ae55426dca2829cc9381e4a8
+SIZE (socketapi-2.2.16.tar.gz) = 572446
diff --git a/net/socketapi/pkg-descr b/net/socketapi/pkg-descr
new file mode 100644
index 000000000000..f147344365cd
--- /dev/null
+++ b/net/socketapi/pkg-descr
@@ -0,0 +1,4 @@
+SocketAPI is the socket API library for the SCTPLIB user-space
+SCTP implementation.
+
+WWW: https://www.uni-due.de/~be0001/sctplib/
diff --git a/net/socketapi/pkg-plist b/net/socketapi/pkg-plist
new file mode 100644
index 000000000000..9dec22a92eed
--- /dev/null
+++ b/net/socketapi/pkg-plist
@@ -0,0 +1,42 @@
+include/cppsocketapi/breakdetector.h
+include/cppsocketapi/condition.h
+include/cppsocketapi/condition.icc
+include/cppsocketapi/internetaddress.h
+include/cppsocketapi/internetaddress.icc
+include/cppsocketapi/internetflow.h
+include/cppsocketapi/internetflow.icc
+include/cppsocketapi/multitimerthread.h
+include/cppsocketapi/multitimerthread.icc
+include/cppsocketapi/portableaddress.h
+include/cppsocketapi/portableaddress.icc
+include/cppsocketapi/randomizer.h
+include/cppsocketapi/randomizer.icc
+include/cppsocketapi/socketaddress.h
+include/cppsocketapi/socketaddress.icc
+include/cppsocketapi/synchronizable.h
+include/cppsocketapi/synchronizable.icc
+include/cppsocketapi/tdin6.h
+include/cppsocketapi/tdmessage.h
+include/cppsocketapi/tdmessage.icc
+include/cppsocketapi/tdsocket.h
+include/cppsocketapi/tdsocket.icc
+include/cppsocketapi/tdstrings.h
+include/cppsocketapi/tdstrings.icc
+include/cppsocketapi/tdsystem.h
+include/cppsocketapi/thread.h
+include/cppsocketapi/thread.icc
+include/cppsocketapi/timedthread.h
+include/cppsocketapi/timedthread.icc
+include/cppsocketapi/tools.h
+include/cppsocketapi/tools.icc
+include/cppsocketapi/unixaddress.h
+include/cppsocketapi/unixaddress.icc
+include/ext_socket.h
+lib/libcppsocketapi.a
+lib/libcppsocketapi.so
+lib/libcppsocketapi.so.2
+lib/libcppsocketapi.so.2.0.2
+lib/libsctpsocket.a
+lib/libsctpsocket.so
+lib/libsctpsocket.so.2
+lib/libsctpsocket.so.2.0.2