aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2013-05-28 17:27:19 +0800
committerehaupt <ehaupt@FreeBSD.org>2013-05-28 17:27:19 +0800
commit0f7ec093dd8839898166fe6629c07d7064938556 (patch)
tree99a219fe2d29cd23662b3bcbbc87db7de3a51a2f /net
parent38c8f3fcc44c604738260571284fa592a87447db (diff)
downloadfreebsd-ports-gnome-0f7ec093dd8839898166fe6629c07d7064938556.tar.gz
freebsd-ports-gnome-0f7ec093dd8839898166fe6629c07d7064938556.tar.zst
freebsd-ports-gnome-0f7ec093dd8839898166fe6629c07d7064938556.zip
Rework previous commit. The problem is not clang 3.3 but rather the fact that
with 1000024 CC became 'cc' rather than 'clang'.
Diffstat (limited to 'net')
-rw-r--r--net/socat/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/net/socat/Makefile b/net/socat/Makefile
index 870fd677d407..b787ecd55320 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -28,16 +28,11 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-# we could be on HEAD where CC is in fact clang 3.3 but since we have no
-# __FreeBSD_version tag from when the 3.3 import happened we have to do some
-# probing
-#
-.if(${OSVERSION} >= 1000000)
-_CLANG!= cc --version | ${HEAD} -1 | ${SED} -e 's/.*clang version \([0-9]\)\.\([0-9]\).*/\1\2/'
-CFLAGS+= -Wno-unused-comparison
+.if(${OSVERSION} >= 1000024)
+CCISCLANG!= ${CC} --version | ${HEAD} -1 | ${GREP} 'clang'
.endif
-.if ${CC} == clang
+.if ${CC} == clang || defined(CCISCLANG)
CFLAGS+= -Wno-unused-comparison
.endif