aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordd <dd@FreeBSD.org>2002-11-03 14:39:59 +0800
committerdd <dd@FreeBSD.org>2002-11-03 14:39:59 +0800
commit124c980985bd5a5bc8e5687b58d28a915f96f07f (patch)
tree270feba36bf30dfcba6050f1656d85212fb204d4 /net
parent6506d994a6d787aeca9addce7851f5dad1f9aef5 (diff)
downloadfreebsd-ports-gnome-124c980985bd5a5bc8e5687b58d28a915f96f07f.tar.gz
freebsd-ports-gnome-124c980985bd5a5bc8e5687b58d28a915f96f07f.tar.zst
freebsd-ports-gnome-124c980985bd5a5bc8e5687b58d28a915f96f07f.zip
Convert to use REINPLACE_CMD instead of PERL and remove USE_PERL5.
Diffstat (limited to 'net')
-rw-r--r--net/dictd/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/net/dictd/Makefile b/net/dictd/Makefile
index af7112b196d3..ba22caad34ed 100644
--- a/net/dictd/Makefile
+++ b/net/dictd/Makefile
@@ -19,7 +19,7 @@ MAINTAINER?= dd@FreeBSD.org
MAN1= dictzip.1
MAN8= dictd.8
-USE_PERL5= yes
+USE_REINPLACE= yes
USE_BISON= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc --with-cflags="${CFLAGS}" \
@@ -32,13 +32,13 @@ INSTALL_TARGET= install.dictd install.dictzip
post-patch:
.for i in dict.1 dictd.8
- @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/$i
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/$i
.endfor
.for i in example.conf
- @${PERL} -pi -e "s|/usr|${PREFIX}|g" ${WRKSRC}/$i
+ @${REINPLACE_CMD} -e "s|/usr|${PREFIX}|g" ${WRKSRC}/$i
.endfor
- @${PERL} -pi -e "s|%%CFLAGS%%|${CFLAGS}|g" ${WRKSRC}/zlib/Makefile
- @${PERL} -pi -e "s|([\ \t(])T_USER|\1T_USERNAME|g" ${WRKSRC}/*.[chly]
+ @${REINPLACE_CMD} -e "s|%%CFLAGS%%|${CFLAGS}|g" ${WRKSRC}/zlib/Makefile
+ @${REINPLACE_CMD} -e "s|([\ \t(])T_USER|\1T_USERNAME|g" ${WRKSRC}/*.[chly]
post-install:
@${MKDIR} ${DATADIR}